General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] SOGo on Solaris


Chronological Thread 
  • From: Tony Pyro < >
  • To:
  • Subject: Re: [SOGo] SOGo on Solaris
  • Date: Sat, 31 Jul 2010 10:04:10 -0400
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=sender:from:mime-version:content-type:subject:date:in-reply-to:to :references:message-id:x-mailer; b=s+NyJltoAuMCRFueQuY8Tf0cgPbuncX2RpIqSwCZSk+BWUCXEtwUBI3OviknhbAXAD Oq1y3xXciTmLPqAgGUcdiWMX98kvejFzL8yw8BU79j2Gd3/Xp53wvy339vVeq26lo5j8 xt8V9jUWTv6L8BL64LOE+drZ2bQa1nIifwHsw=

Here's the status of my Solaris build so far. Any help would be appreciated.

I built gnustep-base but couldn't get it to recognize my installed libgnutls. There is an older one supplied by the OS which gets picked up by the configure script. If I override that using --with-tls-prefix, configure then looks for libgnutls-config (in spite of using --disable-tlstest) which is deprecated and not supplied with my version. So I gave up on TLS entirely by adding --disable-tls.

Next, I tried to build SOPE. Configure ran smoothly, although I haven't tried including postgresql or sqlite headers yet. Make ran for several minutes but eventually failed here:

Making all for tool wod...
 Linking tool wod ...
Undefined                       first referenced
 symbol                             in file
sigsetmask                          ./obj/wod.obj/UnixSignalHandler.m.o
strndup                             ./../../sope-mime/obj/libNGMime.so
behavior_class_add_class            ../../sope-core/NGExtensions/./obj/libNGExtensions.so
sigblock                            ./obj/wod.obj/UnixSignalHandler.m.o
ld: fatal: Symbol referencing errors. No output written to obj/wod
make[5]: *** [obj/wod] Error 1
make[4]: *** [internal-tool-all_] Error 2
make[3]: *** [wod.all.tool.variables] Error 2
make[2]: *** [internal-all] Error 2
make[1]: *** [internal-all] Error 2
make: *** [internal-all] Error 2


I got around a similar error (building gnustep-base) by specifying --with-gnu-linker, but SOPE's configure wouldn't accept this option.

Thanks,
Tony


On Jul 26, 2010, at 6:03 PM, Ludovic Marcotte wrote:

Hi,
I've been slowly working my way through a build of SOGo on a Solaris 10 machine. I know it's not a supported OS but Solaris has few options for open source groupware.
Assuming I can get through all the build problems, is it reasonable to think it will run well? Yes, I've seen the OGo build notes for Solaris 9... they help to a degree. Should we be looking elsewhere?
 
It should work just well, post your progress / questions and we'll be glad to help.

Regards,

--
Ludovic Marcotte
">  ::  +1.514.755.3630  ::  www.inverse.ca
Inverse inc. :: Leaders behind SOGo (www.sogo.nu) and PacketFence (www.packetfence.org)

--
">
https://inverse.ca/sogo/lists




Archive powered by MHonArc 2.6.16.

Top of page