General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Permission denied


Chronological Thread 
  • From: Arvind K < >
  • To:
  • Subject: Re: [SOGo] Permission denied
  • Date: Fri, 6 Aug 2010 14:23:37 +0530
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :content-type; b=R8pzkQEP0yEaMWh4Lqu8yE9fsywnqhhnDwR7a9tnmTecIxesFuNRzI1FDRmd124YvI kuzMYf5R3niCnZ8slUc873QxzUvZ6kAaGbJXJL/EZrP6mwxmJEaf/vjWSi9385KVDj7L CUoHn0JQPRd+RgWEn+bAX+Siwulfb+FuySZJY=

I am pasting my .GNUstepDefaults file, could someone please tell me whats wrong with this ?
http://paste.ubuntu.com/473925/

On 6 August 2010 12:00, Arvind K < "> > wrote:
Hi, I am now getting the web interface, again. :) But the problem of not being able to login still stands. I am pasting the log of /apache2/error.log and also sogo.log when that happens.
/apache2/error.log
[Fri Aug 06 11:49:24 2010] [error] proxy: HTTP: disabled connection for (127.0.0.1)
[Fri Aug 06 11:49:25 2010] [error] proxy: HTTP: disabled connection for (127.0.0.1)
[Fri Aug 06 11:49:25 2010] [error] proxy: HTTP: disabled connection for (127.0.0.1)

sogo.log
<0x0x2cba3f0[SOGoSQLUserProfile]> failed to acquire channel for URL: (nil)
<0x0x2cba3f0[SOGoSQLUserProfile]> failed to acquire channel for URL: (nil)
<0x0x2cba3f0[SOGoSQLUserProfile]> failed to acquire channel for URL: (nil)
127.0.0.1 - - [06/Aug/2010:06:22:50 GMT] "GET /SOGo/ HTTP/1.1" 200 3319/0 0.036 10265 67% 0
2010-08-06 06:24:46.471 sogod[5187] Scanner initialised with nil string
SOGoRootPage Login for user 'Arvind' might not have worked - password policy: 65535  grace: -1  expire: -1  bound: 0
127.0.0.1 - - [06/Aug/2010:06:24:46 GMT] "POST /SOGo/connect HTTP/1.1" 403 34/38 0.025 - - 12K
2010-08-06 06:24:47.622 sogod[5187] Scanner initialised with nil string
SOGoRootPage Login for user 'Arvind' might not have worked - password policy: 65535  grace: -1  expire: -1  bound: 0
127.0.0.1 - - [06/Aug/2010:06:24:47 GMT] "POST /SOGo/connect HTTP/1.1" 403 34/38 0.002 - - 0

I have been seeing that sogo complains of not being able to find its profile URL. I have mentioned it in the configuration file, but yet it complains so.
Thanks in advance.


On 6 August 2010 11:41, Arvind K < " target="_blank"> > wrote:
Thanks a lot. I thought of what you said, changing the ownership, but sogo was not showing this previously in the log. Anyways thanks, I will try doing that. I have got everything setup almost, as in the database part. But I keep getting the error
1)Configurtion for SOGo was not found. So it wont work properly.
2)SOGoProfileURL is not set, even though I have set it in .GNUstepDefaults.
3)Authentication method is not mentioned, which also has been set.


On 6 August 2010 10:14, Abhas Abhinav < " target="_blank"> > wrote:
Arvind:

Good progress. I'm happy that you are asking intelligent questions. :)

To fix this problem just change the ownership of the sogo pid file to that of the sogo user.

Also the mysql table structure is detailed in the install guide. Basically you can have any schema as long as you have certain basic fields with specific names.

Keep it up! Looking forward to more... Just keep at it and don't give up.

-abhas.


------- Original message -------
From: Arvind K < " target="_blank"> >
To: " target="_blank">
Sent: 6.8.'10,  10:01

Hi, All of a sudden, sogo complains of permission being denied on /var/run/sogo/sogo.pid . Here is the paste from sogo.log . Please help me.
2010-08-06 04:17:44.050 sogod[5588] File NSData.m: 1419. In -[NSData writeToFile:options:error:] Open (/var/run/sogo/sogo.pid) failed - Permission denied
2010-08-06 04:19:56.399 sogod[5984] File NSData.m: 1419. In -[NSData writeToFile:options:error:] Open (/var/run/sogo/sogo.pid) failed - Permission denied

--
My Fingerprint:1024D/67CF3C40 :7C43 BB90 1E92 2E8D 647A  5DB0 DC64 0799 67CF 3C40
Arvind: https://launchpad.net/~arvindkhadri
The box said Windoze or better,so i installed Linux
http://techietipsandtricks.blogspot.com
http://xkcd.com/272/
Registered Linux User #46760
arvind_khadri (on irc.freenode.net)








--
My Fingerprint:1024D/67CF3C40 :7C43 BB90 1E92 2E8D 647A  5DB0 DC64 0799 67CF 3C40
Arvind: https://launchpad.net/~arvindkhadri
The box said Windoze or better,so i installed Linux
http://techietipsandtricks.blogspot.com
http://xkcd.com/272/
Registered Linux User #46760
arvind_khadri (on irc.freenode.net)



Archive powered by MHonArc 2.6.16.

Top of page