General discussion on installation and configuration of SOGo

Text archives Help


Re: Re: [SOGo] Cannot access Mail interface after Login


Chronological Thread 
  • From: < >
  • To:
  • Subject: Re: Re: [SOGo] Cannot access Mail interface after Login
  • Date: Mon, 1 Nov 2010 13:37:54 -0400 (EDT)

Thanks for the prompt reply.

My httpd.conf VirtualHosts entries follow:

<VirtualHost 192.168.5.3:80>
## Elastix
ServerAdmin

DocumentRoot /var/www/html
ServerName 192.168.5.3
ErrorLog logs/Elastix-error_log
CustomLog logs/Elastix-access_log common
<Directory "/var/www/html">
# Redirect administration interface to https
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
</Directory>
</VirtualHost>

<VirtualHost 192.168.5.3:8080>
## SoGo
ServerAdmin

DocumentRoot /var/www/html
ServerName 192.168.5.3
ErrorLog logs/SoGo-error_log
CustomLog logs/SoGo-access_log common
Include conf.d/*.config
</VirtualHost>

[Note: I renamed the sogo.conf file to sogo.config to separate what was
included globally and what whas included for the VirtualHost]

Even though I have only specified a redirect to https in the 1st Virtual host,
once I Login to the SOGo interface the URL is redirected to
'https://192.168.5.3/SOGo/so/ian/Mail'. Don't know if that is the expected
behaviour.

SOGo Log excerpt follows:

Nov 01 17:29:16 sogod [2610]: SOGoRootPage successful login for user 'ian' -
expire = -1 grace = -1
127.0.0.1 - - [01/Nov/2010:17:29:16 GMT] "POST /SOGo/connect HTTP/1.1" 200
27/57 0.053 - - 0
127.0.0.1 - - [01/Nov/2010:17:29:16 GMT] "GET /SOGo/ian HTTP/1.1" 302 0/0
0.018
- - 0
127.0.0.1 - - [01/Nov/2010:17:29:16 GMT] "GET /SOGo/ian/view HTTP/1.1" 302 0/0
0.025 - - 0

There does appear to be a relevant error in the ssl_error_log:

[Mon Nov 01 17:29:16 2010] [error] [client 192.168.5.4] File does not exist:
/var/www/html/SOGo, referer: http://192.168.5.3:8080/SOGo/

Hope this information is helpful.

Regards,

Ian Jones



Archive powered by MHonArc 2.6.16.

Top of page