General discussion on installation and configuration of SOGo

Text archives Help


[SOGo] Funambol Installation problem


Chronological Thread 
  • From: Ian Jones < >
  • To:
  • Subject: [SOGo] Funambol Installation problem
  • Date: Wed, 03 Nov 2010 18:14:56 +0000

Hi,

I've been following the instructions to install the Funambol SOGo Connector but get an error during the './install-modules stage'.  Here's the output I get:

     [echo] Funambol Data Synchronization Server will be installed on the Tomcat 6.0.x application server
     [echo] install.modules basedir /opt/Funambol/ds-server
     [echo] Pre installation for modules content-provider-8.7.0,email-connector-8.7.0,foundation-8.7.0,phones-support-8.7.0,webdemo-8.7.0,funambolsogo-1.0.8
     [echo] install.modules basedir /opt/Funambol/ds-server
     [echo] content-provider-8.7.0 pre-installation...
     [echo] content-provider-8.7.0 pre-installation successfully completed
     [echo] install.modules basedir /opt/Funambol/ds-server
     [echo] email-connector-8.7.0 pre-installation...
     [echo] email-connector-8.7.0 pre-installation successfully completed
     [echo] install.modules basedir /opt/Funambol/ds-server
     [echo] foundation-8.7.0 pre-installation...
     [echo] foundation-8.7.0 pre-installation successfully completed
     [echo] install.modules basedir /opt/Funambol/ds-server
     [echo] phones-support-8.7.0 pre-installation...
     [echo] phones-support-8.7.0 pre-installation successfully completed
     [echo] install.modules basedir /opt/Funambol/ds-server
     [echo] webdemo-8.7.0 pre-installation...
     [echo] webdemo-8.7.0 pre-installation successfully completed
     [echo] install.modules basedir /opt/Funambol/ds-server
     [echo] funambolsogo-1.0.8 pre-installation...

     BUILD FAILED
     /opt/Funambol/ds-server/install/install.xml:197: The following error occurred while executing this line:
     /opt/Funambol/ds-server/install/install-modules.xml:106: The following error occurred while executing this line:
     /opt/Funambol/ds-server/install/install-modules.xml:131: Error while expanding /opt/Funambol/ds-server/modules/funambolsogo-1.0.8.s4j


As per the installation instructions I downloaded 'funambolsogo-1.0.8.s4j' from here - http://www.sogo.nu/downloads/backend.html

FYI, here's the content of '/opt/Funambol/ds-server/install.properties'

# ==============================================================================
# Funambol Data Synchronization Server
# ==============================================================================
# Installation properties
# ==============================================================================

#
# The server URI
#
# This parameter is optional: if empty the server will use the
# client request uri
#
server-uri=

# The context path to use to access SyncServer
context-path=/funambol

#
# The DBMS name. One of:
#   - hypersonic
#   - postgresql
#   - mysql
#
dbms=hypersonic

#
# JDBC settings:
#   classpath: the classpath of the JDBC driver
#   url:       the url to access the database with the choosen JDBC driver
#   user:      the db user
#   password:  the user's password
#
#
# Hypersonic
# ==========
#
# jdbc.classpath=<somepath>/hsqldb.jar
# jdbc.driver=org.hsqldb.jdbcDriver
# jdbc.url="jdbc:hsqldb:hsql://<hostname>:1476 # jdbc.user=sa
# jdbc.password=
#
# PostgreSQL
# ==========
#
# jdbc.classpath=<somepath>/postgresql.jar
# jdbc.driver=org.postgresql.Driver
# jdbc.url="jdbc:postgresql://<hostname>/funambol # jdbc.user=funambol
# jdbc.password=funambol
#
# MySQL
# =====
#
# jdbc.classpath=<somepath>/mysql-connector-java-5.0.4-bin.jar
# jdbc.driver=com.mysql.jdbc.Driver
# jdbc.url="jdbc:mysql://[hostname][,failoverhost...][:port]/[dbname]?characterEncoding=UTF-8[&param2=value2] # jdbc.user=funambol
# jdbc.password=funambol
#
#

jdbc.classpath=../tools/hypersonic/lib/hsqldb.jar
jdbc.driver=org.hsqldb.jdbcDriver
jdbc.url="jdbc:hsqldb:hsql://localhost/funambol jdbc.user=sa
jdbc.password=

#
# Modules definitions
#
modules-to-install=content-provider-8.7.0,email-connector-8.7.0,foundation-8.7.0,phones-support-8.7.0,webdemo-8.7.0,funambolsogo-1.0.8


The Apache Commons, JSON and MySQL-Connector versions I'm using are as follows:

json_simple.jar
mysql-connector-java-5.1.13-bin.jar
commons-collections-3.2.1.jar
commons-configuration-1.6.jar
commons-lang-2.4.jar
commons-logging-1.1.1.jar


Any thoughts or suggestions appreciated.

Regards,

Ian Jones








Archive powered by MHonArc 2.6.16.

Top of page