General discussion on installation and configuration of SOGo

Text archives Help


[SOGo] iPhone can't see caldav events


Chronological Thread 
  • From: Ben < >
  • To:
  • Subject: [SOGo] iPhone can't see caldav events
  • Date: Mon, 20 Dec 2010 15:24:05 -0700

I have a weird problem with IOS 4.1: I configured the iPhone to use SOGo's caldav according to the instructions on the website and it works in that I get no errors. In the apache logs I see:

192.168.10.130 - - [20/Dec/2010:15:05:32 -0700] "PROPFIND /SOGo/dav/user/Calendar/ HTTP/1.1" 207 8113 "-" "DAVKit/5.0 (765); iCalendar/5.0 (79); iPhone/4.1 8B117"
192.168.10.130 - - [20/Dec/2010:15:05:33 -0700] "REPORT /SOGo/dav/user/Calendar/personal/ HTTP/1.1" 207 6120 "-" "DAVKit/5.0 (765); iCalendar/5.0 (79); iPhone/4.1 8B117"
192.168.10.130 - - [20/Dec/2010:15:09:26 -0700] "PROPFIND /SOGo/dav/user/Calendar/ HTTP/1.1" 207 8113 "-" "DAVKit/5.0 (765); iCalendar/5.0 (79); iPhone/4.1 8B117"
192.168.10.130 - - [20/Dec/2010:15:09:48 -0700] "PROPFIND /SOGo/dav/user/Calendar/ HTTP/1.1" 207 8113 "-" "DAVKit/5.0 (765); iCalendar/5.0 (79); iPhone/4.1 8B117"
192.168.10.130 - - [20/Dec/2010:15:13:19 -0700] "PROPFIND /SOGo/dav/user/Calendar/ HTTP/1.1" 207 8113 "-" "DAVKit/5.0 (765); iCalendar/5.0 (79); iPhone/4.1 8B117"

But in the calendar, no events show up under any of the listed calendars (iPhone grabbed a list of subscribed calendars). But if I create a new event in a SOGo calendar, it shows up on the iPhone for a few minutes. Then it disappears and shows up in SOGo (website and t-bird). But once it gets into SOGo, the iPhone no longer see it. (And yes, the iPhone is configured to display the relevant calendars).

Any ideas? How can I debug?

Thanks,

Ben



Archive powered by MHonArc 2.6.16.

Top of page