General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Help needed with sogo with ldap and dovecot


Chronological Thread 
  • From: Jeff Folk < >
  • To:
  • Subject: Re: [SOGo] Help needed with sogo with ldap and dovecot
  • Date: Wed, 29 Dec 2010 15:29:17 -0600

Do you have "SOGoForceIMAPLoginWithEmail" defined in your config? If so,
remove it...

Jeff

On Dec 29, 2010, at 3:08 PM,
< >
wrote:

>
> Hi,
>
> i am new to sogo and i got the basics running, but now i think i need help.
>
> So i have debian 5 with postfix and dovecot with pam authentification.
> So now i have installed openldap and sogo and i am able to connect with one
> or
> two users i created in LDAP to the webinterface of sogo.
> But i have problems accessing the emails in sogo.
> I think i have the following problem:
> sogo is connect to dovecot with the user
> " ",
> this is not
> working, i see the following messagefrom mail.log:
> dovecot: imap-login: Disconnected:
> user=< >
>
> When i connect with squirrelmail to dovecot it works, but in the logfile i
> can
> see that the user is connecting only as "chris", not as
> " ".
> To sogo i connect with "chris", but it seems when connecting in the
> background
> to imap (dovecot) the email address is used as username for
> authentification.
>
> Do i have to change something in sogo ?
> What i guess is that i have to change the configuration of dovecot, perhaps
> i
> have to configure LDAP authentification in dovecot.
>
> Anybody here with same environment who can help me how to get it working ?
>
> Thanks a lot
>
> Chris
> --
>
> https://inverse.ca/sogo/lists




Archive powered by MHonArc 2.6.16.

Top of page