General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Timeout after 1.35 upgrade


Chronological Thread 
  • From: Jason Thibeault < >
  • To:
  • Subject: Re: [SOGo] Timeout after 1.35 upgrade
  • Date: Tue, 01 Feb 2011 14:15:33 -0400

Sorry all, I think just found the problem. One server had the session timeout, the other didn't.  This Defaults is from the one that apparently didn't.  I'm going to add it now and test, though I strongly suspect this was an error of my own doing.

Thanks!

On 11-02-01 02:13 PM, Jason Thibeault wrote:
" type="cite"> Hi Ludovic,

Here's my .GNUstepDefaults, sanitized for security.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//GNUstep//DTD plist 0.9//EN" "http://www.gnustep.org/plist-0_9.xml">
<plist version="0.9">
<dict>
    <key>NSGlobalDomain</key>
    <dict>
    </dict>
    <key>sogod</key>
    <dict>
    <key>WOWorkersCount</key>
    <string>10</string>
    <key>OCSEMailAlarmsFolderURL</key>
    <string>mysql://sogo: :3306/sogo/sogo_alarms_folder</string>
    <key>OCSFolderInfoURL</key>
    <string>mysql://sogo: :3306/sogo/sogo_folder_info</string>
    <key>SOGoVacationEnabled</key>
    <string>YES</string>
    <key>SOGoForwardEnabled</key>
    <string>YES</string>
    <key>SOGoSieveScriptsEnabled</key>
    <string>YES</string>
    <key>SOGoMailMessageCheck</key>
    <string>every_5_minutes</string>
    <key>SOGoMailReplyPlacement</key>
    <string>above</string>
    <key>SOGoMailSignaturePlacement</key>
    <string>below</string>
    <key>SOGoMailComposeMessageType</key>
    <string>html</string>
    <key>SOGoACLsSendEMailNotifications</key>
    <string>YES</string>
    <key>SOGoAppointmentSendEMailNotifications</key>
    <string>YES</string>
    <key>SOGoDraftsFolderName</key>
    <string>Drafts</string>
    <key>SOGoFoldersSendEMailNotifications</key>
    <string>NO</string>
    <key>SOGoIMAPServer</key>
    <string>localhost</string>
    <key>SOGoLanguage</key>
    <string>English</string>
    <key>SOGoMailDomain</key>
    <string>olsinc.biz</string>
        <key>SOGoMailPollingIntervals</key>
        <array>
                <string>5</string>
                <string>10</string>
                <string>20</string>
                <string>30</string>
                <string>60</string>
        </array>
    <key>SOGoSuperUsernames</key>
    <array>
        <string>xxxxx</string>
        <string>xxxxx</string>
        <string>xxxxx</string>
        <string>xxxxx</string>
        <string>xxxxx</string>
    </array>
    <key>SOGoMailingMechanism</key>
    <string>smtp</string>
    <key>SOGoProfileURL</key>
    <string>mysql://sogo: :3306/sogo/sogo_user_profile</string>
    <key>SOGoSMTPServer</key>
    <string>localhost</string>
    <key>SOGoSentFolderName</key>
    <string>Sent</string>
    <key>SOGoTimeZone</key>
    <string>America/Halifax</string>
    <key>SOGoTrashFolderName</key>
    <string>Trash</string>
    <key>SOGoUserSources</key>
    <array>
        <dict>
        <key>CNFieldName</key>
        <string>cn</string>
        <key>IDFieldName</key>
        <string>cn</string>
        <key>UIDFieldName</key>
        <string>sAMAccountName</string>
        <key>baseDN</key>
        <string>ou=DOMAIN,dc=domain,dc=com</string>
        <key>bindDN</key>
        <string>CN=LDAP Integration,ou=Technology,ou=Corporate,ou=DOMAIN,dc=domain,dc=com</string>
        <key>bindFields</key>
        <array>
            <string>sAMAccountName</string>
        </array>
        <key>bindPassword</key>
        <string>xxxxx</string>
        <key>canAuthenticate</key>
        <string>YES</string>
        <key>displayName</key>
        <string>auth_ldap</string>
        <key>hostname</key>
        <string>dc.domain.com</string>
        <key>id</key>
        <string>auth_ldap</string>
        <key>isAddressBook</key>
        <string>NO</string>
        <key>port</key>
        <string>389</string>
        <key>type</key>
        <string>ldap</string>
        </dict>
            <dict>
                <key>CNFieldName</key>
                <string>cn</string>
                <key>IDFieldName</key>
                <string>cn</string>
                <key>UIDFieldName</key>
                <string>uid</string>
                <key>baseDN</key>
                <string>cn=users,dc=xxxx,dc=local</string>
                <key>bindDN</key>
                <string>uid=ldap,cn=users,dc=xxxx,dc=local</string>
                <key>bindFields</key>
                <array>
                    <string>uid</string>
                </array>
                <key>MailFieldNames</key>
                <array>
                    <string>mail</string>
                </array>
                <key>bindPassword</key>
                <string>xxxxx</string>
                <key>canAuthenticate</key>
                <string>YES</string>
                <key>displayName</key>
                <string>First Apple LDAP</string>
                <key>hostname</key>
                <string>xx.xx.xx.xx</string>
                <key>id</key>
                <string>auth_firstldap</string>
                <key>isAddressBook</key>
                <string>YES</string>
                <key>port</key>
                <string>389</string>
                <key>type</key>
                <string>ldap</string>
            </dict>
            <dict>
        <key>CNFieldName</key>
        <string>cn</string>
        <key>IDFieldName</key>
        <string>cn</string>
        <key>UIDFieldName</key>
        <string>uid</string>
        <key>baseDN</key>
        <string>cn=users,dc=yyyy,dc=local</string>
        <key>bindDN</key>
        <string>uid=ldap,cn=users,dc=yyyy,dc=local</string>
        <key>bindFields</key>
        <array>
            <string>uid</string>
        </array>
                <key>MailFieldNames</key>
                <array>
                    <string>mail</string>
                </array>
        <key>bindPassword</key>
        <string>xxxxx</string>
        <key>canAuthenticate</key>
        <string>YES</string>
        <key>displayName</key>
        <string>Second Apple LDAP</string>
        <key>hostname</key>
        <string>yy.yy.yy.yy</string>
        <key>id</key>
        <string>auth_secondldap</string>
        <key>isAddressBook</key>
        <string>YES</string>
        <key>port</key>
        <string>389</string>
        <key>type</key>
        <string>ldap</string>
            </dict>
        <dict>
        <key>CNFieldName</key>
        <string>cn</string>
        <key>IDFieldName</key>
        <string>cn</string>
        <key>UIDFieldName</key>
        <string>sAMAccountName</string>
        <key>baseDN</key>
        <string>ou=DOMAIN,dc=domain,dc=com</string>
        <key>bindDN</key>
        <string>CN=LDAP Integration,ou=Technology,ou=Corporate,ou=DOMAIN,dc=domain,dc=com</string>
        <key>bindFields</key>
        <array>
            <string>sAMAccountName</string>
        </array>
        <key>bindPassword</key>
        <string>xxxxx</string>
        <key>canAuthenticate</key>
        <string>NO</string>
        <key>displayName</key>
        <string>ActiveDirectory</string>
        <key>filter</key>
        <string>(objectClass=user and mail='*' and objectCategory=person and not memberOf='SOGo-AddressHidden' and not userAccountControl:1.2.840.113556.1.4.803:=2)</string>
        <key>hostname</key>
        <string>olsinckeser01.olsinc.biz</string>
        <key>id</key>
        <string>ldap_addressbook</string>
        <key>isAddressBook</key>
        <string>YES</string>
        <key>port</key>
        <string>389</string>
        <key>type</key>
        <string>ldap</string>
        </dict>
    </array>
    </dict>
</dict>
</plist>


On 11-02-01 01:09 PM, Ludovic Marcotte wrote:
" type="cite"> On 11-02-01 11:37 AM, Jason Thibeault wrote:
" type="cite"> My users have been complaining of the same issue since the upgrade to 1.3.5a as well.  I have OCSSessionsFolderURL configured, and the table is populated.  At first I thought the issue was with roundrobin DNS (I have two SOGo servers configured roundrobin, with MySQL dual-master replication).  However, when specifying which server I want to go to by editing the URL to point to the specific server, I still get timed out anywhere from two to five minutes after my last click.

Another issue has come up -- occasionally, when attempting to view specific emails, I've been getting the login prompt in the message reading pane, which won't go away until I hit Disconnect and try to log in again.  I suspect this is related, though the rest of the GUI does not disappear.

If there's anything I can provide to help troubleshoot this, do let me know.  Thanks!
Show us your complete .GNUstepDefaults

Regards,
-- 
Ludovic Marcotte

 
 ">
   ::  +1.514.755.3630  ::  www.inverse.ca
Inverse inc. :: Leaders behind SOGo (www.sogo.nu) and PacketFence (www.packetfence.org) 

--
Jason Thibeault
OLS | IT Manager, Kentville

office 902.690.2249 | cell 902.679.7710 | fax 902.678.7200
email "> | website www.onlinesupport.com

Notice This communication, including any attachments, is confidential. It is intended only for the person or persons to whom it is addressed. If you have received this e-mail in error, please notify the sender. Avis Cette communication, y compris tous les attachements, est confidentielle. On le prévoit seulement pour la personne ou les personnes à qui il est adressé. Si vous avez reçu cet email par erreur, informez svp l'expéditeur.

--
Jason Thibeault
OLS | IT Manager, Kentville

office 902.690.2249 | cell 902.679.7710 | fax 902.678.7200
email "> | website www.onlinesupport.com

Notice This communication, including any attachments, is confidential. It is intended only for the person or persons to whom it is addressed. If you have received this e-mail in error, please notify the sender. Avis Cette communication, y compris tous les attachements, est confidentielle. On le prévoit seulement pour la personne ou les personnes à qui il est adressé. Si vous avez reçu cet email par erreur, informez svp l'expéditeur.



Archive powered by MHonArc 2.6.18.

Top of page