General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Multiple IMAP servers with authentication in Active Directory


Chronological Thread 
  • From: Ladislav Pašek < >
  • Cc:
  • Subject: Re: [SOGo] Multiple IMAP servers with authentication in Active Directory
  • Date: Mon, 21 Feb 2011 10:34:57 +0100
  • Organization: VALBEK-CZ s.r.o.

It seems that in latest nightly build is SOGoIMAPServer directive functional. So I've tried to configure SOGo for our two mail servers. But I'm doing somewhere error. It is not possible to login to defined second domain. Just the first is working.

This is my testing config:

{
NSGlobalDomain = {
};
sogod = {
OCSFolderInfoURL = "mysql://xxx:xxx@192.168.1.254:3306/sogo/sogo_folder_info";
SOGoProfileURL = "mysql://xxx:xxx@192.168.1.254:3306/sogo/sogo_user_profile";
OCSSessionsFolderURL = "mysql://xxx:xxx@192.168.1.254:3306/sogo/sogo_sessions_folder";
SOGoLanguage = Czech;
SOGoTimeZone = Europe/Prague;
SOGoVacationEnabled = YES;
SOGoSieveScriptsEnabled = YES;
SOGoForwardEnabled = YES;
SOGoDraftsFolderName = Drafts;
SOGoSentFolderName = Sent;
SOGoTrashFolderName = Trash;
SOGoOtherUsersFolderName = "Other Users";
SOGoSharedFolderName = "Shared Folders";
SOGoMailAuxiliaryUserAccountsEnabled = YES;
SOGoMailShowSubscribedFoldersOnly = YES;
SOGoACLsSendEMailNotifications = YES;
SOGoFoldersSendEMailNotifications = YES;
SOGoAppointmentSendEMailNotifications = YES;
domains = {
prodex.sk = {
SOGoMailDomain = prodex.sk;
SOGoMailingMechanism = smtp;
SOGoSMTPServer = 192.168.9.231;
SOGoIMAPServer = "imaps://192.168.9.231";
SOGoIMAPAclConformsToIMAPExt = YES;
SOGoUserSources = (
{
type = ldap;
CNFieldName = cn;
IDFieldName = cn;
UIDFieldName = mail;
filter = "(objectclass=user)";
baseDN = "ou=PRX,ou=_Uzivatele,dc=valbek,dc=cz";
bindDN = "cn=xxx,dc=valbek,dc=cz";
bindFields = (mail);
bindPassword = xxx;
canAuthenticate = YES;
displayName = "Active Directory";
hostname = 192.168.1.1;
id = directory;
isAddressBook = YES;
port = 389;
}
);
};
valbek.cz = {
SOGoMailDomain = valbek.cz;
SOGoMailingMechanism = smtp;
SOGoSMTPServer = 192.168.1.254;
SOGoIMAPServer = "imaps://192.168.1.254";
SOGoIMAPAclConformsToIMAPExt = YES;
SOGoUserSources = (
{
type = ldap;
CNFieldName = cn;
IDFieldName = cn;
UIDFieldName = mail;
filter = "(objectclass=user)";
baseDN = "ou=_Uzivatele,dc=valbek,dc=cz";
bindDN = "cn=xxx,dc=valbek,dc=cz";
bindFields = (mail);
bindPassword = xxx;
canAuthenticate = YES;
displayName = "Active Directory";
hostname = 192.168.1.1;
id = directory;
isAddressBook = YES;
port = 389;
}
);
};
}
}
}


Great! Good to hear that positive news.

Best regards

Ladislav

Dne 16.2.2011 16:08, Ludovic Marcotte napsal(a):
On 11-02-16 6:28 AM, Ladislav Pašek wrote:
is there any progress on this bug? I'd like to have SOGo server for more mail
domains and also put it outside of our imap servers.

Would it be in 1.3.6 as Ludovic declared?
Sure!
Because in nightly builds is problem still exist.
Because the problem isn't fixed, nor marked as fixed in the BTS ;-)

Regards,





Archive powered by MHonArc 2.6.18.

Top of page