General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] sogo-1.3.5a-1.el5.i386.rpm not working on RHEL5.3


Chronological Thread 
  • From: Stephen Ingram < >
  • To:
  • Subject: Re: [SOGo] sogo-1.3.5a-1.el5.i386.rpm not working on RHEL5.3
  • Date: Mon, 28 Feb 2011 14:25:49 -0800
  • Organization: Supersource Consulting

Allen-

If you get memcached and libmemcached from the inverse (SOGo) repository along with the rest of SOGo, all dependencies should be resolved.

Steve

Allen Chen wrote:
Stephen Ingram wrote:
Allen-

Allen Chen wrote:
I am not doing updates on the live server. It's a new test installation with the SOGo1.3.3 database.
I just copied MySQL(SOGo-1.3.3) database to the new RHEL5.3 server,
and install SOGo-1.3.5a rpms, run sql-update-1.3.3_to_1.3.4-mysql.sh to update MySQL database.
What I installed on the test server:
# rpm -qa | egrep "sope|gnustep|mem|gcc-objc|libff|libobjc"|sort
gcc-objc-4.1.2-44.el5 #this one is from RHEL CD
gnustep-base-1.20.2-1
gnustep-make-2.4.0-1
libffi-3.0.6-1
libmemcached-0.34-1
libobjc-4.1.2-44.el5 # this one is from RHEL CD
memcached-1.4.2-1.el5
sope49-appserver-4.9-20110127_1664.el5.1
sope49-cards-1.3.5a-1.el5
sope49-core-4.9-20110127_1664.el5.1
sope49-gdl1-4.9-20110127_1664.el5.1
sope49-gdl1-contentstore-1.3.5a-1.el5
sope49-gdl1-mysql-4.9-20110127_1664.el5.1
sope49-ldap-4.9-20110127_1664.el5.1
sope49-mime-4.9-20110127_1664.el5.1
sope49-sbjson-2.3.1-20110127_1664.el5.1
sope49-xml-4.9-20110127_1664.el5.1
and memcached is running on the test server.
Have you ever installed these rpms on a new RHEL5 or CentOS5?
or have you ever compiled SOPE-1.3.5 on a new RHEL5?
I mean it's done on a separate server(not from yum or upgrade on an exiating one).

Yes, I have installed this from scratch (rpm) on a CentOS 5 server. I don't have gcc-objc on my system. I'm guessing that was there for compiling purposes.

I'm not sure what else to suggest as your log errors are really short. I guess I would run over my config again and maybe check to see if the rpm packages are intact.

Steve
Hi, Steve

I tried to install all those rpms on CentOS 5.5, but run into dependency issue:
memcached-1.4.2-1.el5 needs libevent-1.1a, and CentOS 5.5 has libevent-1.4.13-1 installed.
So I can not install memcached-1.4.2-1.el5.i386.rpm on CentOS 5.5.
Can you let me know which version of CentOS 5 you are using for SOGo 1.3.5a, or
how do you fix this dependency issue.

Thanks,
Allen



Archive powered by MHonArc 2.6.18.

Top of page