General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Cannot Log Into SOGo After Install


Chronological Thread 
  • From: Nathan Acks < >
  • To:
  • Subject: Re: [SOGo] Cannot Log Into SOGo After Install
  • Date: Tue, 24 Jan 2012 08:45:44 -0700
  • Organization: EcoPunk.info

On Tuesday, January 24, 2012 06:31:01 am Pascal Gienger wrote:
> Le 23/01/2012 03:04, Nathan Acks a écrit :
> > I've been searching Google and the list here all day, and can't find
> > anything that seems to match my problem. Basically, I have SOGo set up
> > to use a custom port on my server, and can access it at
> Hi Nathan,
>
> first: your mail fell into my spam filter (Ironport), you were my first
> false positive for 5 years now... :-(
>
> > Jan 22 17:22:00 sogod [27842]: |SOGo| starting method 'GET' on uri
> > '/SOGo/myuser' Jan 22 17:22:00 sogod
> > [27842]:<0x0x700c78[SOGoWebAuthenticator]> tried wrong password for
> > user
> > '1477YRibp8H12nCyarBR4mXtiSE6NOfcK5fYify0hLcLblrcGrvTCOsru/h+M8ibjRTeFw
> > u/i/Zz4kP12Ro/nw=='!
> [...]
>
> > <key>SOGoUserSources</key>
> > <array>
> > <dict>
> >
> > <key>canAuthenticate</key>
> > <string>YES</string>
> > <key>displayName</key>
> > <string>SOGo Users</string>
> > <key>id</key>
> > <string>sogo_db</string>
> > <key>isAddressBook</key>
> > <string>YES</string>
> > <key>type</key>
> > <string>sql</string>
> > <key>userPasswordAlgorithm</key>
> > <string>sha</string>
> > <key>viewURL</key>
> >
<string>mysql://sogo:sogopassword@localhost:3306/sogo/sogo_auth</str
> > ing>>
> > </dict>
> > </array>
>
> How the user passwords are coded in your "sogo_auth" table? How the
> columns are named?

I'm using the suggested format from the SOGo installation guide (page 23), so
the table schema looks something like

sogo_auth ( c_uid VARCHAR(25),
c_name VARCHAR(25),
c_password VARCHAR(100),
c_cn VARCHAR(50),
mail VARCHAR(50) )

Passwords are encoded using SHA1 (which at least in MySQL seems to be the
same
as "SHA", though in OpenSSL they're different).

I've tried using userPasswordAlgorithm "none" and "md5" as well (recoding my
password in sogo_auth as appropriate), and interestingly enough always get
actual login failures (SOGo complaining about a "bad user name or password")
in both those cases. Which might be related, but I'm not sure how...

--
Nathan Acks
http://ecopunk.info/

+--------+ pub 4096R/D7F3999A 2009-05-08
|\ O--m /| Nathan Acks <nathan at ecopunk.info>
|/`----'\| Using public key encryption is like signing a letter and
+--------+ sending it in a sealed envelope. http://gnupg.org/



Archive powered by MHonArc 2.6.18.

Top of page