General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] CardDAV sync on iPhone


Chronological Thread 
  • From: Georg Bretschneider < >
  • To:
  • Subject: Re: [SOGo] CardDAV sync on iPhone
  • Date: Thu, 26 Jan 2012 20:59:16 +0100

Hi to myself :) and everyone,

I forgot to ask about a problem. Accessing my address books via CardDav
in iOS is not a big problem (for now). But I can't use my mail address
as username, actually, I have to use the localpart - which is equal to
the corresponding uid in my LDAP database.

So:
Server: mail.blabla:8443
Username:

Password: hackme,
is not working. But when I type "user" as the username, everything works.

Problem is, I setup a multi domain environment. Right now I did not test
what happens, if a there is a user with the same uid in the second ldap
database.

Possibilies:
1) One of us won't be able to access his address book, because
ldapsearch will retrieve one occurance of the uid in both databases and
the user with the correct password wins.
2) Everything will fuckin' break.

For CalDav the user has to type in a very long URL and than use the
localpart (or uid) as username. That works, but, to be honest, is not
very user-friendly. It should be accessible like with CardDav - just
using the mail address as username.

The only thing I CAN image to bypass this problem is to alter my SOGo
config for user authentication. I activated the option that users can
login to the WebGUI with their email address, which then will be
translated to localpart-->uid, rest-->nirvana for the LDAP query. So, I
hoped that this will allow me to use my email address as username with
CardDav.

I'm a little stuck here.


Bye
Georg



Am 13.11.2011 23:28, schrieb Georg Bretschneider:
> Hi,
>
> I can't create a CardDAV account on my iPhone (iOS 5).
> Error message: Couldn't verify account informations.
>
> I read the following for help:
> http://www.mail-archive.com/ /msg06051.html
> http://wiki.sogo.nu/iOS (plus attachements)
>
> Apache is listening on port 8443 and I can establish a secure connection
> in my webbrowser. When I connect to https://<server>:8843 I will be
> asked for my credentials and then a blank page is shown.
>
> I setup my config mails as suggested in the above links. CalDAV syncing
> works without a problem. I also specified the exact port during my
> CardDAV account creation on my iPhone.
>
> The error logs aren't filled with any errors.
>
> Does anybody has a suggestion for me?
>
> btw: I setup SOGo for a multi domain environment, so far everything
> works like a charm. And the SOGo TB Connector isn't compatible with TB
> 8.0. Will the addon be updated anytime soon?
>
> Bye
> Georg



Archive powered by MHonArc 2.6.18.

Top of page