General discussion on installation and configuration of SOGo

Text archives Help


[SOGo] openchange connector doesn't start


Chronological Thread 
  • From: Selçuk Mıynat < >
  • To:
  • Subject: [SOGo] openchange connector doesn't start
  • Date: Fri, 29 Jun 2012 09:55:18 +0300

Hi,

I've install SOGo 2.0.0rc1. Now i'm trying to use openchange. I've installed openchange from the sogo-nightly-build repo (Openchange version is 1.0.0.20120625.sogo).

When i try to start it (# /etc/init.d/openchange-ocsmanager start), it gaves me this error message:

# tail -f /var/log/ocsmanager/ocsmanager.log :

Traceback (most recent call last):
File "/usr/bin/paster", line 9, in <module>
load_entry_point('PasteScript==1.7.5', 'console_scripts', 'paster')()
File "/usr/lib/python2.6/site-packages/paste/script/command.py", line 84, in run
invoke(command, command_name, options, args[1:])
File "/usr/lib/python2.6/site-packages/paste/script/command.py", line 123, in invoke
exit_code = runner.run(args)
File "/usr/lib/python2.6/site-packages/paste/script/command.py", line 218, in run
result = self.command()
File "/usr/lib/python2.6/site-packages/paste/script/serve.py", line 276, in command
relative_to=base, global_conf=vars)
File "/usr/lib/python2.6/site-packages/paste/script/serve.py", line 313, in loadapp
**kw)
File "/usr/lib/python2.6/site-packages/paste/deploy/loadwsgi.py", line 204, in loadapp
return loadobj(APP, uri, name=name, **kw)
File "/usr/lib/python2.6/site-packages/paste/deploy/loadwsgi.py", line 225, in loadobj
return context.create()
File "/usr/lib/python2.6/site-packages/paste/deploy/loadwsgi.py", line 625, in create
return self.object_type.invoke(self)
File "/usr/lib/python2.6/site-packages/paste/deploy/loadwsgi.py", line 110, in invoke
return fix_call(context.object, context.global_conf, **context.local_conf)
File "/usr/lib/python2.6/site-packages/paste/deploy/util/fixtypeerror.py", line 57, in fix_call
val = callable(*args, **kw)
File "/usr/lib/python2.6/site-packages/ocsmanager/config/middleware.py", line 43, in make_app
config = load_environment(global_conf, app_conf)
File "/usr/lib/python2.6/site-packages/ocsmanager/config/environment.py", line 122, in load_environment
mstore = mapistore.MAPIStore(config['ocsmanager']['main']['mapistore_root'])
SystemError: error in mapistore_init
Removing PID file /var/run/ocsmanager/ocsmanager.pid

I've tried to start it with this command:

# /usr/bin/paster serve /etc/ocsmanager/ocsmanager.ini --pid-file /var/run/ocsmanager/ocsmanager.pid --log-file /var/log/ocsmanager/ocsmanager.log

And then the error message is:

[mapistore_init:83]: Storage backend initialization failed
Modules/gcmodule.c:348: visit_decref: Assertion "gc->gc.gc_refs != 0" failed.
refcount was too small
object : <module 'errors' (built-in)>
type : module
refcount: 2
address : 0x1afc520
Aborted

I couldn't find where the problem is, anybody help?

Cheers.

--
Selçuk Mıynat



  • [SOGo] openchange connector doesn't start, Selçuk Mıynat, 06/29/2012

Archive powered by MHonArc 2.6.18.

Top of page