General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Timezone Issues with Calendar Web-UI / SOGo 2.0 Daily (2012-07-26)


Chronological Thread 
  • From: Christian Vilhelm < >
  • To: < >
  • Subject: Re: [SOGo] Timezone Issues with Calendar Web-UI / SOGo 2.0 Daily (2012-07-26)
  • Date: Thu, 02 Aug 2012 13:05:23 +0200

Le 2012-07-31 14:06, Andreas Balg a écrit :
No comment? Nobody else with this problem in sogo 2? This suddenly
appeared while in the beginning it worked flawlessly here. I expected
it to go away with one of the numerous updates to 2.0 daily again but
it didn't. Where could I have to look at to find out of this ?

I also have the same problem, events shift when created or moved, it seems related to bug 1766 (http://www.sogo.nu/bugs/bug_view_advanced_page.php?bug_id=1766). Database entries for the events are correct, but are displayed incorrectly.
It also happens with 1.3.xx versions, since several versions. It began just after an upgrade on a working installation. It also appears on a fresh 2.0 install.
I tried several things related to timezones but the bug happens regardless of the timezone specified.

Am 07/26/12 12:38, schrieb Andreas Balg:
Hello everybody,

excuse me if I should have missed anything in the documentation - I am having severe trouble since some time ago with the times displayed and stored for events. They differ in the Web-UI and other Clients (TB+Lightning+SOGO Integrator, EMCLient, Android-Calendar via CalDAV).

When I initially create an event in the calendar web-UI - the event time is stored and displayed eith an offset of 4(!) hours.

E.g. Create it with 9:00-10:00 - initally at creation it will be stored and displayed as 5:00-6:00 in WEB-UI (-4 hours off) and with -2 hours offset in any CalDAV-Client (Android/TB) - After initial creation I open it agaoin in WEB UI, change the time back to 9:00-10:00 and save the event again then it is displayed in the Web-UI as 7:00-8:00 (-2 hours offset) and will be displayed correctly in other clients. When I create an event in any other client it works as expected but is displayed with offset in the webUI.

What did I miss here ?? Can't find anything wrong or

IN .GNUStepDefaults I configured the local Timezone (same as Client)

<key>SOGoTimeZone</key>
<string>Europe/Zurich</string>

The user himself configured his timezone as "Europe/Zurich" as well in SOGo's web-UI preferences.

What's wrong so far? Or is there still an unresolved bug I did not see? Or is my setup wrong ??

Cheers Andreas



--
/~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\
| Christian Vilhelm :

|
| Reality is for people who lack imagination |
\____________________________________________________________________/


  • Re: [SOGo] Timezone Issues with Calendar Web-UI / SOGo 2.0 Daily (2012-07-26), Christian Vilhelm, 08/02/2012

Archive powered by MHonArc 2.6.18.

Top of page