General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Connection/Auth/Session problems


Chronological Thread 
  • From: Christian Mack < >
  • To:
  • Subject: Re: [SOGo] Connection/Auth/Session problems
  • Date: Fri, 01 Feb 2013 16:09:40 +0100

Hello Maik Derstappen


Am 2013-02-01 11:24, schrieb Maik Derstappen:
> Am 30.01.2013 18:31, schrieb Christian Mack:
>>
>> Am 2013-01-28 11:10, schrieb Maik Derstappen:
>>> Am 24.01.2013 14:01, schrieb Christian Mack:
>>>> Am 2013-01-24 13:12, schrieb Maik Derstappen:
>>>>> i'm running SOGo 2.0.3a-1 on Debian and the user are in a PosgreSQL
>>>>> database.
>>>>> This works fine, but after sometimes the user is silently logged out
>>>>> from the web UI.
>>>>> Also Calendarclients like Thunderbird or ical ask sometimes for login
>>>>> date, although the login date are saved in the application.
>>>>> I can't find anything in the sogo logfiles thats related to this
>>>>> problem.
>>>>>
>>>>> has anyone such problems?
>>>>>
>>>> Have you set a valid OCSSessionsFolderURL ?
>>>> If you have not set this, then you always will be thrown out after the
>>>> time set for SOGoCacheCleanupInterval .
>>>> That's because you don't have sessions then, just caching.
>>> this is set:
>>>
>>> <key>OCSSessionsFolderURL</key>
>>>
>>> <string>postgresql://sogo:xxx@127.0.0.1:5432/sogo/sogo_sessions_folder</string>
>>>
>> Is the passwort, server and port correct ?
>> If not, correct it.
>>
>> Can you select from sogo_session_folder with this above settings ?
> yes, otherwise it would never work, but it does ;)
>> If not, drop that table, it only contains session infos, so don't worry.
>> SOGo will create it anew on startup.
>>
>>
>>> Now i have activate the cronjob but the same problem occurs.
>>>
>>> The logout is not always after the same time and the problem with
>>> thunderbird is more like it could not start a new connection after
>>> restarting the program. But this problem in thunderbird occurs mostly,
>>> when i start it on next day, but not when i close and start it again.
>>>
>> Do you shutdown your client machine or send it to hibernation?
>>
>> I had problems with that after wakeup on one windows machine.
> yes my workstation is some times only in hibernation, but we have the
> same problems with mobile devices like iphones.
>>> Today i had to put in my password 6 times into Thunderbird, befor it
>>> works and in my SOGo log files i saw this:
>>>
>>> 127.0.0.1 - - [28/Jan/2013:10:50:30 GMT] "OPTIONS
>>> /SOGo/dav/maik.derstappen%40inqbus.de/Calendar/ HTTP/1.0" 200 0/0 0.010
>>> - - 0
>>> Jan 28 10:50:30 sogod [3261]: <0x0xb81f4518[SOGoDAVAuthenticator]> got
>>> malformed basic credentials!
>>> 127.0.0.1 - - [28/Jan/2013:10:50:30 GMT] "OPTIONS
>>> /SOGo/dav/maik.derstappen%40inqbus.de/Calendar/ HTTP/1.0" 401 27/0 0.012
>>> - - 0
>>> Jan 28 10:50:30 sogod [3262]: <0x0xb81f49c0[SOGoDAVAuthenticator]> got
>>> malformed basic credentials!
>>> 127.0.0.1 - - [28/Jan/2013:10:50:30 GMT] "PROPFIND
>>> /SOGo/dav/maik.derstappen%40inqbus.de/Calendar/ HTTP/1.0" 401 27/98
>>> 0.011 - - 0
>>> Jan 28 10:50:30 sogod [3262]: <0x0xb81f49c0[SOGoDAVAuthenticator]> got
>>> malformed basic credentials!
>>> 127.0.0.1 - - [28/Jan/2013:10:50:30 GMT] "PROPFIND
>>> /SOGo/dav/maik.derstappen%40inqbus.de/Calendar/ HTTP/1.0" 401 27/98
>>> 0.002 - - 0
>>> Jan 28 10:52:05 sogod [3261]: <0x0xb81f4518[SOGoDAVAuthenticator]> got
>>> malformed basic credentials!
>>> 127.0.0.1 - - [28/Jan/2013:10:52:05 GMT] "PROPFIND
>>> /SOGo/dav/maik.derstappen%40inqbus.de/Calendar/ HTTP/1.0" 401 27/98
>>> 0.001 - - 0
>>> Jan 28 10:52:05 sogod [3261]: <0x0xb81f4518[SOGoDAVAuthenticator]> got
>>> malformed basic credentials!
>>> 127.0.0.1 - - [28/Jan/2013:10:52:05 GMT] "PROPFIND
>>> /SOGo/dav/maik.derstappen%40inqbus.de/Calendar/ HTTP/1.0" 401 27/98
>>> 0.006 - - 0
>>> 127.0.0.1 - - [28/Jan/2013:10:52:05 GMT] "OPTIONS
>>> /SOGo/dav/maik.derstappen%40inqbus.de/Calendar/ HTTP/1.0" 200 0/0 0.024
>>> - - 0
>>> Jan 28 10:52:05 sogod [3262]: <0x0xb82b1b18[SoWebDAVRenderer]> got bogus
>>> port information from webserver: mailcenter.inqbus.de
>>> 127.0.0.1 - - [28/Jan/2013:10:52:05 GMT] "PROPFIND
>>> /SOGo/dav/maik.derstappen%40inqbus.de/Calendar/ HTTP/1.0" 207 349/98
>>> 0.006 - - 0
>>> Jan 28 10:52:05 sogod [3261]: <0x0xb82c2ef8[SoWebDAVRenderer]> got bogus
>>> port information from webserver: mailcenter.inqbus.de
>>> 127.0.0.1 - - [28/Jan/2013:10:52:05 GMT] "PROPFIND
>>> /SOGo/dav/maik.derstappen%40inqbus.de/Calendar/ HTTP/1.0" 207 349/98
>>> 0.004 - - 0
>>> Jan 28 10:52:05 sogod [3261]: <0x0xb82c2ef8[SoWebDAVRenderer]> got bogus
>>> port information from webserver: mailcenter.inqbus.de
>>> 127.0.0.1 - - [28/Jan/2013:10:52:05 GMT] "PROPFIND
>>> /SOGo/dav/maik.derstappen%40inqbus.de/Calendar/ HTTP/1.0" 207 349/98
>>> 0.004 - - 0
>>>
>> I never saw that in my logs before.
>> Seems to me that your webserver is sending invalid data to sogo.
>> But if it did, then you should not be able to login at all.
>> Weired.
>
Do you have an additional HTTP-Proxy before your SOGo?

If that's not the case, you have to open a bug report at
http://www.sogo.nu/bugs


Kind regards,
Christian Mack

--
Christian Mack
Gruppe Informationsdienste
Rechenzentrum Universität Konstanz


  • Re: [SOGo] Connection/Auth/Session problems, Christian Mack, 02/01/2013

Archive powered by MHonArc 2.6.18.

Top of page