General discussion on installation and configuration of SOGo

Text archives Help


[SOGo] Force all sogo and sope package to be updates when updating sogo


Chronological Thread 
  • From: Igor Vitorac < >
  • To: Sogo < >
  • Subject: [SOGo] Force all sogo and sope package to be updates when updating sogo
  • Date: Mon, 01 Apr 2013 13:48:41 +0200

It seems that there are problems with dependency checks when updating SOGo.

I have tried to update sogo from 2.0.2a to 2.0.4b (on CentOS 6.2) and after performing "yum update sogo", sogo was completely useless.

Browser error:

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /SOGo/.

Reason: Error reading from remote server


Sogo.log

EXCEPTION: <NSException: 0x16dca6c> NAME:NSInvalidArgumentException REASON:SOGo(instance) does not recognize activeUser INFO:(null)
Apr 01 11:28:51 sogod [2981]: <0x0x14453c4[WOWatchDogChild]> child 3163 exited
Apr 01 11:28:51 sogod [2981]: <0x0x14453c4[WOWatchDogChild]> (terminated due to signal 6, coredump)
Apr 01 11:28:51 sogod [2981]: <0x0x1542c04[WOWatchDog]> child spawned with pid 3185

I have found that some users had similar errors in the past if they have not updated manually some sope packages.
After doing full system update "yum update" (CentOS was updated to 6.4), sogo was operational again.

Could we make an improvement in installation process to force all sogo and sope packages to be updated as well?

Thanks,
Igor





  • [SOGo] Force all sogo and sope package to be updates when updating sogo, Igor Vitorac, 04/01/2013

Archive powered by MHonArc 2.6.18.

Top of page