General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Delegate user's mailbox


Chronological Thread 
  • From: Szládovics Péter < >
  • To:
  • Subject: Re: [SOGo] Delegate user's mailbox
  • Date: Fri, 05 Apr 2013 13:51:02 +0200

2013-04-05 11:48 keltezéssel, Szládovics Péter írta:
" type="cite">
2013-04-05 11:22 keltezéssel, Szládovics Péter írta:
" type="cite">
2013-04-05 09:48 keltezéssel, Szládovics Péter írta:
" type="cite">
2013-04-04 22:15 keltezéssel, Jean Raby írta:
Are you sure the ACL / shared mailbox setup is ok on the dovecot side?

Have a look here: http://wiki2.dovecot.org/SharedMailboxes/Shared
In particular, check the "Shared mailbox listing" section.

If this isn't setup properly, dovecot won't return the shared
mailboxes to SOGo,
SOGo won't have any way of knowing that the shared mailbox exists
(even if the user has access to it).
Thanks! It's missing.
I'll try it, and report the results.

Hmmm. I set it up, delegated some folder, but the other users folderlist didn't see any changes.

/var/mail/shared-mailboxes.db has been created with 666 rights, and it contains correct informations.

I tried to restart sogo service, but it didn't help.

I think there is some misconfigured thing yet... but where and what?

The problem there is at the IMAP side, because the thunderbird even see the shared folders.

My dovecot config is:
...
Dovecot LDAP config:
...

My fault is:

###########
namespace {
  type = private
  separator = /
  prefix =
  inbox = yes
}
namespace {
  type = shared
  separator = /
  prefix = shared/%%u/
  location = maildir:/var/mail/%%u:INDEX=/var/mail/%u/shared/%%u
  list = children
}
###########

This missing from my dovecoc.conf.

But a question:
Can I use the email address instead of username?

%%<something> instead of %%u? On SOGo web UI is not problem, but under Thunderbird I see only the pure username.



Archive powered by MHonArc 2.6.18.

Top of page