General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] LDAP address book not working


Chronological Thread 
  • From: Paul van der Vlis < >
  • To:
  • Subject: Re: [SOGo] LDAP address book not working
  • Date: Wed, 24 Apr 2013 18:15:36 +0200

On 24-04-13 17:36, Christian Mack wrote:
> Hello Paul van der Vlis
>
>
> Am 2013-04-24 15:25, schrieb Paul van der Vlis:
>>
>> My LDAP address book is not working. What will be wrong?
>> The authentication works fine.
>>
>> I don't know if the "id" field is important?
>> Now there is only some name in that field.
>>
>> SOGoUserSources = (
>> {
>> type = ldap;
>> CNFieldName = cn;
>> IDFieldName = uid;
>> UIDFieldName = uid;
>> baseDN = "ou=Users,dc=domain,dc=local";
>> bindDN = "cn=admin,dc=domain,dc=local";
>> bindPassword = secret;
>> canAuthenticate = YES;
>> displayName = "LDAP addresses";
>> hostname = "192.168.28.240";
>> id = contacts;
>> isAddressBook = YES;
>> port = 389;
>> filter = "(mail='*@*')";
>> }
>> );
>>
>
> This should work.
> What problem do you have with it?
> Can you not see the global address book "LDAP addresses" in the SOGo
> webinterface at all?

I see an "LDAP addresses" address book in Sogo.

> Can you not find addresses while searching in the global addressbook?

Hmm, it works now!

I searched for someone who was not correct in the LDAP. I can find other
persons...

> What error message do you get?
>
> id is the internal reference for that User Source.
> Therefore it must be unique within the configuration of SOGo.

Thanks for your help!

With regards,
Paul van der Vlis.




--
Paul van der Vlis Linux systeembeheer, Groningen
http://www.vandervlis.nl/




Archive powered by MHonArc 2.6.18.

Top of page