General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Openchange on Ubuntu


Chronological Thread 
  • From: Alex Ferrara < >
  • To:
  • Subject: Re: [SOGo] Openchange on Ubuntu
  • Date: Sun, 2 Jun 2013 11:48:35 +1000

No takers on this?

I have also posted to Sernet support to get their take on this. I suspect the
problem is in their deb packages, but I am surprised nobody has tried this.
Sernet provide up to date debian packages of Samba4, instead of the old
versions in the Debian/Ubuntu repos.


On 25/05/2013, at 1:21 AM, Alex Ferrara
< >
wrote:

> Hi everyone,
>
> I am having trouble installing the Openchange part of SOGo on Ubuntu 12.04.
> The issue I have is that I am using the enterprise samba.com (Sernet)
> Samba4 packages, and they are actually named differently to the standard
> samba4 packages. I think because of this, apt-get/dpkg are getting confused
> about the dependency tree.
>
> Any help would be appreciated.
>
> I have Samba4 and SOGo working fantastically otherwise.
>
> tachyon:~ ✓ # apt-get install openchangeserver sogo-openchange
> openchangeproxy openchange-ocsmanager openchange-rpcproxy
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
> openchange-ocsmanager : Depends: python-ocsmanager (=
> 1:2.0.r3665-1~inverse1.0) but it is not going to be installed
> openchangeproxy : Depends: samba4 (>= 4.0.0~) but it is not going to be
> installed
> Depends: libdcerpc-server0 but it is not going to be
> installed
> Depends: libdcerpc0 but it is not going to be installed
> Depends: libmapi0 but it is not going to be installed
> Depends: libmapiproxy0 but it is not going to be installed
> openchangeserver : Depends: samba4 (>= 4.0.0~) but it is not going to be
> installed
> Depends: libdcerpc-server0 but it is not going to be
> installed
> Depends: libmapiproxy0 but it is not going to be
> installed
> sogo-openchange : Depends: libmapi0 but it is not going to be installed
> Depends: libmapiproxy0 but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.
> tachyon:~ ✓ # dpkg -l "*samba*"
> Desired=Unknown/Install/Remove/Purge/Hold
> |
> Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
> |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
> ||/ Name Version
> Description
> +++-===============================-===============================-==============================================================================
> un libsamba-credentials-dev <none> (no
> description available)
> un libsamba-credentials0 <none> (no
> description available)
> un libsamba-hostconfig-dev <none> (no
> description available)
> un libsamba-hostconfig0 <none> (no
> description available)
> un libsamba-policy-dev <none> (no
> description available)
> un libsamba-policy0 <none> (no
> description available)
> un libsamba-util-dev <none> (no
> description available)
> un libsamba-util0 <none> (no
> description available)
> un python-samba <none> (no
> description available)
> un samba <none> (no
> description available)
> un samba-ad-dc <none> (no
> description available)
> un samba-client <none> (no
> description available)
> un samba-common <none> (no
> description available)
> un samba-common-bin <none> (no
> description available)
> un samba-dev <none> (no
> description available)
> un samba-dsdb-modules <none> (no
> description available)
> un samba-ldb-tools <none> (no
> description available)
> un samba-testsuite <none> (no
> description available)
> un samba-tools <none> (no
> description available)
> in samba4 <none> (no
> description available)
> un samba4-clients <none> (no
> description available)
> un samba4-common <none> (no
> description available)
> un samba4-common-bin <none> (no
> description available)
> un samba4-dev <none> (no
> description available)
> un samba4-testsuite <none> (no
> description available)
> ii sernet-samba 99:4.0.6-1
> SMB/CIFS file, print, and login server for Unix
> ii sernet-samba-ad 99:4.0.6-1 Samba
> Active Directory Domain Controller
> ii sernet-samba-client 99:4.0.6-1 a
> LanManager-like simple client for Unix
> ii sernet-samba-common 99:4.0.6-1 Samba
> common files used by both the server and the client
> ii sernet-samba-libs 99:4.0.6-1 Samba
> common library files used by both the server and the client
> ii sernet-samba-libsmbclient0 99:4.0.6-1 Shared
> library that allows applications to talk to SMB servers
> ii sernet-samba-libwbclient0 99:4.0.6-1 client
> library for interfacing with winbind service
> ii sernet-samba-winbind 99:4.0.6-1 Samba
> nameservice integration server
> Alex Ferrara
> Director
> Receptive IT Solutions
>
>
>
>
> --
>
> https://inverse.ca/sogo/lists

Alex Ferrara
Director
Receptive IT Solutions





  • Re: [SOGo] Openchange on Ubuntu, Alex Ferrara, 06/01/2013

Archive powered by MHonArc 2.6.18.

Top of page