General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Re: 404 on login


Chronological Thread 
  • From: Ron Scott-Adams < >
  • To:
  • Cc:
  • Subject: Re: [SOGo] Re: 404 on login
  • Date: Thu, 6 Jun 2013 06:07:51 -0400

Well done! Hope all else works out well… sometimes, it just takes another set of eyes on the problem!


Ron Scott-Adams
"Soap and education are not as sudden as a massacre, but they are more deadly in the long run." (Mark Twain)







Hi ..

ok I see it :)

there is the ":" missing :)

thx


2013/6/6 < " target="_blank"> >
Hi Ron,


cat SOGo.conf:

Alias /SOGo.woa/WebServerResources/ \
      /usr/lib64/GNUstep/SOGo/WebServerResources/
Alias /SOGo/WebServerResources/ \
      /usr/lib64/GNUstep/SOGo/WebServerResources/
AliasMatch /SOGo/so/ControlPanel/Products/(.*)/Resources/(.*) \
           /usr/lib64/GNUstep/SOGo/$1.SOGo/Resources/$2

<Directory /usr/lib64/GNUstep/SOGo/>
    AllowOverride None
    Order deny,allow
    Allow from all

    # Explicitly allow caching of static content to avoid browser specific behavior.
    # A resource's URL MUST change in order to have the client load the new version.
    <IfModule expires_module>
      ExpiresActive On
      ExpiresDefault "access plus 1 year"
    </IfModule>
</Directory>

<LocationMatch "^/SOGo/so/ControlPanel/Products/.*UI/Resources/.*\.(jpg|png|gif|css|js)">
  SetHandler default-handler
</LocationMatch>

## Uncomment the following to enable proxy-side authentication, you will then
## need to set the "SOGoTrustProxyAuthentication" SOGo user default to YES and
## adjust the "x-webobjects-remote-user" proxy header in the "Proxy" section
## below.
#<Location /SOGo>
#  AuthType XXX
#  Require valid-user
#  SetEnv proxy-nokeepalive 1
#  Allow from all
#</Location>

ProxyRequests Off
SetEnv proxy-nokeepalive 1
ProxyPreserveHost On

# When using CAS, you should uncomment this and install cas-proxy-validate.py
# in /usr/lib64/cgi-bin to reduce server overloading
#
#   Order deny,allow
#   Allow from your-cas-host-addr
# </Proxy>

ProxyPass /SOGo http://127.0.0.1:20000/SOGo retry=0

## adjust the following to your configuration
  RequestHeader set "x-webobjects-server-port" "80"
  RequestHeader set "x-webobjects-server-name" "sogo2.mydom.net"
  RequestHeader set "x-webobjects-server-url" "http//sogo2.mydom.net"

## When using proxy-side autentication, you need to uncomment and
## adjust the following line:
#  RequestHeader set "x-webobjects-remote-user" "%{REMOTE_USER}e"

  RequestHeader set "x-webobjects-server-protocol" "HTTP/1.0"

  AddDefaultCharset UTF-8

  Order allow,deny
  Allow from all
</Proxy>


2013/6/6 < " target="_blank"> >

Hi..

When I remove the /(null) it seems to work


2013/6/5 < " target="_blank"> >

hi..

ive just setup 2.0.5a on centos.
When i login I got a "404 Not Found"

Not Found

The requested URL /(null):/SOGo/so/hpeter/Calendar was not found on this server.


the sogo.log shows:


Jun 05 20:46:25 sogod [3370]: SOGoRootPage successful login from '10.0.40.34' for user 'hpeter' - expire = -1  grace = -1

10.0.40.34 - - [05/Jun/2013:20:46:25 GMT] "POST /SOGo/connect HTTP/1.1" 200 27/46 0.167 - - 0

10.0.40.34 - - [05/Jun/2013:20:46:25 GMT] "GET /SOGo/hpeter HTTP/1.1" 302 0/0 0.002 - - 0

10.0.40.34 - - [05/Jun/2013:20:46:25 GMT] "GET /SOGo/hpeter/view HTTP/1.1" 302 0/0 0.004 - - 0

access.log
10.0.40.34 - - [05/Jun/2013:20:46:25 +0200] "GET /SOGo.woa/WebServerResources/busy.gif HTTP/1.1" 200 825 "http://so                             go2.mydom.net/SOGo/" "Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0"
10.0.40.34 - - [05/Jun/2013:20:46:25 +0200] "POST /SOGo/connect HTTP/1.1" 200 27 "http://sogo2.mydom.net/SOGo/" "Mo                             zilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0"
10.0.40.34 - - [05/Jun/2013:20:46:25 +0200] "GET /SOGo/hpeter HTTP/1.1" 302 - "http://sogo2.mydom.net/SOGo/" "Moz                             illa/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0"
10.0.40.34 - - [05/Jun/2013:20:46:25 +0200] "GET /SOGo/hpeter/view HTTP/1.1" 302 - "http://sogo2.mydom.net/SOGo/"                              "Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0"
10.0.40.34 - - [05/Jun/2013:20:46:25 +0200] "GET /(null):/SOGo/so/hpeter/Calendar HTTP/1.1" 404 312 "http://sogo2                             .mydom.net/SOGo/" "Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0"

Any ideas ?

Hans








Archive powered by MHonArc 2.6.18.

Top of page