General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] email bouncing


Chronological Thread 
  • From: Szládovics Péter < >
  • To: SOGo lista < >
  • Subject: Re: [SOGo] email bouncing
  • Date: Fri, 27 Sep 2013 23:39:46 +0200

2013-09-27 23:08 keltezéssel, J. írta:
" type="cite">



From: Szládovics Péter ">< >
To: J. ">< >
Sent: Thursday, September 26, 2013 12:23 PM
Subject: Re: [SOGo] email bouncing

2013-09-26 17:58 keltezéssel, J. írta:

2013-09-26 00:50 keltezéssel, J. írta:
I've got ldap authentication set up for postfix and dovecot and have several domains being served by the machine. For two of the domains email is coming through ok, but on the others it's bouncing with "User doesn't exist:". There is an email alias attribute set per user called "AlternateAddress" and for example, a user has:

mail: " target="_blank" href="mailto: ">
AlternateAddress: " target="_blank" href="mailto: ">
AlternateAddress: " target="_blank" href="mailto: ">

the first two work, but the third bounces. Is there a place I need to tell the auth mechanism which domains are ok or should this set up work? (our setup is very similar to the example files that Peter sent earlier today. Something like: query_filter = (|(mail=%s)(AlternateAddress=%s)) )

possible related issue: mail is showing up in my inbox in Thunderbird, but not in the SOGo web client when I log in.

I thing the problem is not the domain, bit the name part of the email.
The mail source (query_filter = (|(mail=%s)(AlternateAddress=%s)) ) is PK, but what is your result attribute, and what are the parameters of the mda agent?

Yes, you're right. I tried sending an email out last night about that, but yahoo's server was somehow blacklisted and it was bouncing, but that's correct. Domains can be changed, but the username part is what's failing/bouncing.

This is the dovecot ldap setting:
auth_bind = yes
pass_filter = (&(accountStatus=active)(uid=%Ln))
user_filter = (uid=%Ln)
user_attrs = uid=home=/var/vmail/users/%L$

This is postfix:
query_filter = (|(mail=%s)(AlternateAddress=%s))
result_attribute = uid

Because you is using %Ln instead of %u in dovecot

When I make that change in dovecot, everything bounces, even mail sent to the main email address.

Have you any relevant log entries, or we should figure out the reason of your exactly problem? :)

--
Szládovics, Péter

Onlinedemo.HU
Any sufficiently advanced technology is indistinguishable from magic.
Arthur C. Clarke



Archive powered by MHonArc 2.6.18.

Top of page