General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Updates.php script


Chronological Thread 
  • From: Szládovics Péter < >
  • To:
  • Subject: Re: [SOGo] Updates.php script
  • Date: Mon, 30 Sep 2013 17:34:09 +0200

2013-09-30 17:06 keltezéssel, Labolinux írta:
" type="cite"> Dear Friends,

I need your help to figure out what is wrong with my updates.php script.
I installed SOGo on Centos 6.4, and everything is working fine.

Now i want my users to be able to use thunderbird connectors.
The manual installintion of plugins (sogo-connector, sogo-integrator, lightning)
is going fine.
  • I downloaded the updates.php script and putted it in /var/www/html/downloads/extensions/
  • I uncompressed sogo-integrator.xpi and modified extensions.rdf file
  • I enabled mod_rewrite in apache's configuration

When i type in the browser this: &version=0.00">http://aynam.com/downloads/extensions/updates.php?plugin= &version=0.00    
I get such an output:

                                                <RDF>
                                                <Description about= ">"urn:mozilla:extension: ">
                                                <em:updates>
                                                <Seq>
                                                <li>
                                                <Description>
                                                 <em:version>24.0.0</em:version>
                                                <em:targetApplication>
                                                <Description>
                                                <em:id>{3550f703-e582-4d05-9a08-453d09bdfdc6}</em:id>
                                                <em:minVersion>24.0</em:minVersion>
                                                <em:maxVersion>25.*</em:maxVersion>
                                                <em:updateLink>/integrator.xpi</em:updateLink>
                                                </Description>
                                                </em:targetApplication>
                                                </Description>
                                                    </li></Seq>
                                                </em:updates>
                                                </Description>
                                                </RDF>
After that I think it shall be ok but when i install the integrator and restart TB the plugin update never finish.

for more information i'll add my updates.php script and a vew of extensions.rdf.
Thank you in advance.


Labolinux
Aynam Zongo M.

This:
<em:updateLink>/integrator.xpi</em:updateLink>

Would be look like:
<em:updateLink>http://aynam.com/downloads/extensions/integrator.xpi</em:updateLink>

Change the line 79 of the aynam.php from:
<em:updateLink><?php echo dirname(getenv('SCRIPT_URI')) . '/' . $plugin["filename"] ?></em:updateLink>

To:
<em:updateLink><?php echo 'http://aynam.com/downloads/extensions/' . $plugin["filename"] ?></em:updateLink>

--
Szládovics, Péter

Onlinedemo.HU
Any sufficiently advanced technology is indistinguishable from magic.
Arthur C. Clarke



Archive powered by MHonArc 2.6.18.

Top of page