General discussion on installation and configuration of SOGo

Text archives Help


[SOGo] sogo apt repository breaking sssd on wheezy (libldb1)


Chronological Thread 
  • From: mourik jan heupink < >
  • To:
  • Subject: [SOGo] sogo apt repository breaking sssd on wheezy (libldb1)
  • Date: Thu, 23 Jan 2014 17:29:02 +0100

Hi all,

On a test machine I'm running wheezy with samba4/sssd. I wanted to test SOGo authentication etc, so i added the regular sogo repository.

Then (without yet installing sogo) I do apt-get update & apt-get upgrade, and:

root@debian72:/var/www# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
libldb1 libtevent0
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 167 kB of archives.

If I run these two updates, I end up with a newer version of libldb1 (1:1.1.13-1 vs 1:1.1.6-1) which basically breaks the stock sssd:

root@debian72:/etc# /etc/init.d/sssd restart
ldb: module version mismatch in ../src/ldb_modules/memberof.c : ldb_version=1.1.13 module_version=1.1.6
ldb: failed to initialise module /usr/lib/x86_64-linux-gnu/ldb/modules/ldb/memberof.so : Unavailable
[FAIL] Starting System Security Services Daemon: sssd failed!
root@debian72:/etc#

So I don't know if this is a bug that should be added to bugzilla (let me know if I should do this) but I'm sending this here mainly as a heads-up to all of you.

Regards,
MJ



Archive powered by MHonArc 2.6.18.

Top of page