General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] SOGo does not start with 2 SOGoUserSources


Chronological Thread 
  • From: Francis Lachapelle < >
  • To:
  • Subject: Re: [SOGo] SOGo does not start with 2 SOGoUserSources
  • Date: Wed, 29 Jan 2014 12:12:27 -0500


On Jan 27, 2014, at 1:42 PM, Cedric Perrot
< >
wrote:

> Thanks Christian for your response.
>
> I am trying to implement groups as describe in
> http://www.sogo.nu/files/docs/SOGo%20Installation%20Guide.pdf page 22.
>
> I applied the changes however it does not change that sogo does not start.
> One defined UserSource in SOGOUserSources is ok however 2 won't start.
> I tried to separate the 2 sources with and without comma but nothing seems
> to work.
>
>
> 2014-01-27 18:32:01.944 sogo-ealarms-notify[15827] File NSDictionary.m:
> 625. In -[NSDictionary initWithContentsOfFile:] Contents of file
> '/etc/sogo/sogo.conf' does not contain a dictionary
> <0x0x1cd1b50[SOGoStartupLogger]> Cannot read configuration from
> '/etc/sogo/sogo.conf'. Aborting
>
> I am getting above error message. Do I have a syntactical problem?
> I think the error message is misleading as /etc/sogo/sogo.conf can be read.

Attach your complete sogo.conf (without the passwords).

> -----Original Message-----
> From:
>
>
> [mailto: ]
> On Behalf Of Christian Mack
> Sent: Mittwoch, 15. Januar 2014 13:39
> To:
>
> Subject: Re: [SOGo] SOGo does not start with 2 SOGoUserSources
>
> Hello Cedric Perrot
>
>
> Am 2014-01-14 20:44, schrieb Cedric Perrot:
>>
>> I am having an issue with installing groups. As soon as I add an
>> additional user source sogo doesn’t start up.
>>
>> As soon as I add the second source with type = ldap; sogo fails to start.
>>
>> I am not getting any logs in /var/log/sogo/sogo.log
>>
>> Can anyone help?
>>
>>
>> This is my SOGoUserSources:
>>
>> SOGoUserSources = (
>> {
>> CNFieldName = displayName;
>> IDFieldName = cn;
>> MailFieldNames = (
>> mail,
>> otherMailbox
>> );
>> SearchFieldNames = (
>> sn,
>> sAMAccountName,
>> mail,
>> otherMailbox,
>> displayName,
>> title
>> );
>> UIDFieldName = mailNickName;
>> baseDN = "cn=users,dc=pesto,dc=net";
>> bindDN = "cn=administrator,cn=users,dc=pesto,dc=net";
>> bindFields = (
>> mailNickname
>> );
>> bindPassword = xxxxxxx;
>> canAuthenticate = YES;
>> displayName = "Shared Addresses";
>> hostname = "127.0.0.1:389";
>> id = samba;
>> isAddressBook = YES;
>> mapping = {
>> mozillasecondemail =
>> otherMailbox;
>> mozillaworkurl = wWWHomePage;
>> nsaimid = sAMAccountName;
>> street = streetAddress;
>> };
>> },
> < cut >
>
> Try instead with:
> mapping = {
> mozillasecondemail = ("otherMailbox",
> "mozillasecondemail");
> mozillaworkurl = ("wWWHomePage", "mozillaworkurl");
> nsaimid = ("sAMAccountName", "nsaimid");
> street = ("streetAddress", "street");
> };
>
>
> Kind regards,
> Christian Mack
>
> --
> Christian Mack
> Gruppe Informationsdienste
> Rechenzentrum Universität Konstanz




Archive powered by MHonArc 2.6.18.

Top of page