General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] BB10 ActiveSync problem


Chronological Thread 
  • From: Szládovics Péter < >
  • To: SOGo lista < >
  • Subject: Re: [SOGo] BB10 ActiveSync problem
  • Date: Mon, 31 Mar 2014 16:28:16 +0200

2014-03-18 10:19 keltezéssel, Szládovics Péter írta:
Hi,

I updated my SOGo server to 2.2.1 early and our Android clients are started woking fine.
Yesterday I try to set up my nephew's BlackBerry 10 phone (it has ActiveSync client by default), but the procedure went fail.
We didn't see mails/folders on the phone, and also couldn't send.

Is this a known problem?

In the log I found some entries:

2014-03-17 19:32:16.249 sogod[2163] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='RIM-Z10-STL100-1/10
.2.1.2141'
Mar 17 19:32:16 sogod [2163]: [ERROR] <0x0xb93e9960[NGLdapAttribute]> could not convert value of objectSid to string
Mar 17 19:32:16 sogod [2163]: [ERROR] <0x0xb9332948[NGLdapAttribute]> could not convert value of jpegPhoto to string
Mar 17 19:32:16 sogod [2163]: [ERROR] <0x0xb94b2f78[NGLdapAttribute]> could not convert value of thumbnailPhoto to string
Mar 17 19:32:16 sogod [2163]: [ERROR] <0x0xb9368010[NGLdapAttribute]> could not convert value of objectGUID to string
94.248.210.145 - - [17/Mar/2014:19:32:16 GMT] "OPTIONS /SOGo/Microsoft-Server-ActiveSync HTTP/1.1" 200 0/0 0.042 - - 0
2014-03-17 19:32:30.161 sogod[2163] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='RIM-Z10-STL100-1/10.2.1.2141'
94.248.210.145 - - [17/Mar/2014:19:32:30 GMT] "OPTIONS /SOGo/Microsoft-Server-ActiveSync HTTP/1.1" 200 0/0 0.002 - - 0
2014-03-17 19:32:30.946 sogod[2163] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='RIM-Z10-STL100-1/10.2.1.2141'
EXCEPTION: <NSException: 0xb92e7300> NAME:NSInvalidArgumentException REASON:-[nil processProvision:inResponse:]: unrecognized selector sent to instance (null) INFO:(null)


Mar 17 19:35:37 sogod [28580]: <0x0xb8a20c70[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
Mar 17 19:35:37 sogod [28580]: <0x0xb8a20c70[SOGoCache]> Using host(s) 'localhost' as server(s)
2014-03-17 19:35:37.041 sogod[28580] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='RIM-Z10-STL100-1/10.2.1.2141'
2014-03-17 19:35:37.042 sogod[28580] Note(SoObject): SoDebugKeyLookup is enabled!
2014-03-17 19:35:37.042 sogod[28580] Note(SoObject): SoDebugBaseURL is enabled!
2014-03-17 19:35:37.042 sogod[28580] Note(SoObject): relative base URLs are enabled.
94.248.210.145 - - [17/Mar/2014:19:35:37 GMT] "POST /SOGo/Microsoft-Server-ActiveSync?Cmd=Settings&DeviceType=BlackBerry&User=tomi&DeviceId=BB2AC1A3EF HTTP/1.1" 200 19/20 0.006 - - 1M
2014-03-17 19:35:37.096 sogod[28580] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='RIM-Z10-STL100-1/10.2.1.2141'
EXCEPTION: <NSException: 0xb8b8e1c0> NAME:NSInvalidArgumentException REASON:-[nil processProvision:inResponse:]: unrecognized selector sent to instance (null) INFO:(null)
Mar 17 19:35:37 sogod [2146]: <0x0xb8b05998[WOWatchDogChild]> child 28580 exited


This problem has gone since 2.2.2.
:)



Archive powered by MHonArc 2.6.18.

Top of page