General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Activesync Outlook 2013


Chronological Thread 
  • From: Martin Simovic < >
  • To:
  • Subject: Re: [SOGo] Activesync Outlook 2013
  • Date: Tue, 3 Jun 2014 14:29:55 +0200

Hi Ludovic,

On 03 Jun 2014, at 13:42, Ludovic Marcotte
< >
wrote:

> On 2014-06-03, 5:59 AM, Martin Simovic wrote:
>> If I reconfigure the account with this setting emails will show up back 1
>> month.
> One thing you could look at is if it takes longer than 10 mins for a sogod
> child process to generate the response. You would see a mention in the logs
> like "pid XYZ has been hanging in the same request for X mins". It X
> reaches 10 mins, I'll get killed by the parent process.
>
> When you tell Outlook to sync all mails, it usually splits its requests
> in512 messages chunks. You could try to overwrite that setting using the
> SOGoMaximumSyncWindowSize configuration parameter. Set it to 50 and see
> where you get at - perhaps your IMAP server is too slow or your SOGo server
> is too slow in processing the IMAP responses and at generating the huge XML
> blob to return.

I do not see the "pid XYZ has been hanging in the same request” log entry,
however I have noticed this one:

sogod [4140]: [ERROR] <0x0x7f1480bd55c0[NGImap4Connection]> could not fetch
18640 uids for url: imap://johndoe@localhost/Archive/

When adjusting SOGoMaximumSyncWindowSize = 50 message seems to have
disappeared, no emails in Outlook though regardless the setting.

Best Regards
Martin.


Archive powered by MHonArc 2.6.18.

Top of page