General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Outlook logon to SOGo/OpenChange/Samba fails


Chronological Thread 
  • From: Anantha Padmanaban Potty < >
  • To:
  • Subject: Re: [SOGo] Outlook logon to SOGo/OpenChange/Samba fails
  • Date: Tue, 17 Jun 2014 22:32:48 +0530

Hi,

thanks for the reply.

I have already removed /var/lib/sogo/GNUstep/Defaults/.GNUstepDefaults. The config in use file is /etc/sogo/sogo.conf

and yes, I have run openchange_newuser --create USERNAME. Also run the openchange_provision and openchange_provision --openchangedb commands as instructed ...

could something be missing from the openchange_newuser script? could you point me to what can be checked to verify whether the script has *REALLY* done what it is supposed to?

regards,

--- Anantha P K Potty


On Tue, Jun 17, 2014 at 9:57 PM, Martin Simovic < > wrote:
Hi,

On 15 Jun 2014, at 17:41, Anantha Padmanaban Potty < > wrote:

I have been trying to install Samba (4.1.7), OpenChange (2.1-QUADRANT) and SOGo (and SOPE 2.2.5) from sources.

All setup for SOGo is working fine when accessing through web and using Thunderbird/Lightening ...

However, on access using Outlook samba crashes with the exception "Uncaught exception MAPIStoreIOException, reason: 'OCSFolderInfoURL' is not set", though the setting is definitely there in /etc/sogo/sogo.conf!

googling suggests "ln -s ~sogo/GNUstep /root". Tried it but no luck!

Your sogo configuration should be in /etc/sogo/sogo.conf rather then in /var/lib/sogo/GNUstep/Defaults/.GNUstepDefaults


Debugging a little using GDB shows that the value of user (sogoUser) is null in the function folderTableURL in OpenChange/MAPIStoreUserContext.m (with a hint to the UserContext ('self' in folderTableURL) not being populated fully?).

Did you run openchange_newuser —create USERNAME ?

M.





Archive powered by MHonArc 2.6.18.

Top of page