General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] sogo-tool 'lost connection' errors afetr update to SOGo 2.2.5


Chronological Thread 
  • From: Tanstaafl < >
  • To:
  • Subject: Re: [SOGo] sogo-tool 'lost connection' errors afetr update to SOGo 2.2.5
  • Date: Wed, 18 Jun 2014 07:00:03 -0400

Thanks for the reply Christian - more inline below...

On 6/18/2014 4:09 AM, Christian Mack wrote:
Am 2014-06-17 16:24, schrieb Charles Marcus:
2014-06-17 03:32:14.985 sogo-tool[24652] ERROR: could not open MySQL4
connection to database 'sogo': Lost connection to MySQL server at
'reading authorization packet', system error: 104
<0x0x172b410[GCSChannelManager]> could not open channel
<MySQL4Channel[0x0x15e31b0] connection=0x(null)> for URL:
mysql://user: :3306/sogo/sogo_sessions_folder
<0x0x172b410[GCSChannelManager]> will prevent opening of this channel 5
seconds after 2014-06-17 03:32:01 -0400 2014-06-17 03:32:14.988
sogo-tool[24652] Can't aquire channel

Anyone have any ideas? Everything seems to be working fine, and like I
said, they only happen once per day (except twice today)...

We see more connections to the database since SOGo 2.2.4.

I'm curious, how many more? In other words, is it a lot (double or more)? Or just a little (10% increase, etc)...

Also - I'm curious what you and/or others who are using [my][postgre]sql or mariadb have set for

max_connections
max_user_connections

Are there any connection tuning (preferably sql related, but I imagine the number of connections SOGo requires is similar or the same regardless of what backend is used) recommendations for SOGo anywhere? Searching the install doc for 'connection' didn't reveal anything.

This error says, you lost a connection in mid transport of data and it
can not open a new one.
That is a really generic problem.
Perhaps your network is busy.

I doubt any of the above. First, the times these happen are outside normal business hours. If it had to do with a busy network, it would be happening during business hours.

My network is fairly small - 60 or so users - but, they are all using shared Calendars & Address Books (at least 3 of each, more in a few cases), so maybe I do need to tune the mysql connections.

Perhaps you run out of port numbers.

What do you mean 'run out of port numbers'? This is connecting to mariadb over TCP on port 3306 - one port.

Perhaps you have not enough file descriptors.

My SOGo server is on a different box than my SQL server - so, do you mean file descriptors on the SOGo box or the SQL box? And wouldn't there be other symptoms? And more importantly, again, this happens at odd times - the first few times at about 3:00am or so, so when the load on the server is at its lowest.

But I'll investigate this further.

Thanks again



Archive powered by MHonArc 2.6.18.

Top of page