General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Outlook logon to SOGo/OpenChange/Samba fails


Chronological Thread 
  • From: Anantha Padmanaban Potty < >
  • To:
  • Subject: Re: [SOGo] Outlook logon to SOGo/OpenChange/Samba fails
  • Date: Tue, 24 Jun 2014 09:50:32 +0530

Hi,

Solved this issue. Posting here so others can get a solution for this issue
(googling for it did not give me the solution ...)

It seems my kernel did not have support for xattr. Enabled it and viola,
outlook synchronization succeeded.

Not tested completely though, so could hit other roadblocks, but surely this
issue with "OCSFolderInfoURL is not set" is gone.

Thanks & Regards,

--- Anantha Potty


On Thu, Jun 19, 2014 at 10:38 AM, Anantha Padmanaban Potty < > wrote:
Hi,

ran the
<sourcepath>/setup/openchange_provision
<sourcepath>/setup/openchange_provision --openchangedb
<sourcepath>/setup/openchange_newuser --create user1

no luck!!

also, I found no difference between the output of these commands when running from install vs from source.

As I had mentioned in my original post, "sogoUser" is missing at the time the Exception is raised. So the contexts table is not getting populated fully/correctly.

Is there any check which can be run on the tdb/ldb files under /var/lib/samba to get some idea what could be wrong?

regards,

--- Anantha Potty

On Wed, Jun 18, 2014 at 6:59 PM, Martin Simovic < > wrote:


On 17 Jun 2014, at 19:02, Anantha Padmanaban Potty < > wrote:

and yes, I have run openchange_newuser --create USERNAME. Also run the openchange_provision and openchange_provision --openchangedb commands as instructed ...

could something be missing from the openchange_newuser script? could you point me to what can be checked to verify whether the script has *REALLY* done what it is supposed to?

I remember that when installing from source openchange commands had to be run from source directory rather then from install one. E.g if your git checkout was in ~/openchange then you’d run ~/openchange/setup/openchande_newuser —create …. etc. instead from install directory (/usr/local)

BTW, install doc is not great, there are some redundant / incorrect steps in it. I got to working setup combining various docs from sogo.nu, openchage.org and iabsis.com and understanding what is done in each step. My plan was to write a “proper” setup documentation, but did not get a chance yet. :(

Best Regards
Martin.
 





Archive powered by MHonArc 2.6.18.

Top of page