General discussion on installation and configuration of SOGo

Text archives Help


[SOGo] Mixup with proxy setup - Service Temporarily Unavailable


Chronological Thread 
  • From: Dominique < >
  • To: SOGo User List < >
  • Subject: [SOGo] Mixup with proxy setup - Service Temporarily Unavailable
  • Date: Tue, 29 Jul 2014 12:08:25 +0200

Hi,

My server just crashed so I decided to reorganize my setup after the
reinstall....
I used to have SOGo running on the server itself, but in my new config,
I created a VM on top of the server, just for SOGo.
Got the install done again, restored the backup, and voila, the SOGo VM
works, SOGo works except that I can only access it within the LAN.

Due to ISP's router limitation, I had to route all traffic to server and
then reroute from there. So the traffic goes as follow:
Internet <-> ISP Router <-> Main Server (192.168.1.50) <-> SOGo VM
(192.168.1.51)
to do that I added an apache2 proxy in the main server
<VirtualHost *:80>
ProxyPreserveHost On
ProxyPass / http://192.168.1.51/
ProxyPassReverse / http://192.168.1.51/
ServerAdmin

ServerName sogo.mydomain.com
</VirtualHost>

Which allows for external access to the apache server on the VM.
However I must be missing something in the SOGo.conf file, as all I get
is "Service Temporarily Unavailable"

My sogo.conf file for the SOGO VM is as follow (retrieved from backup
and modified for Ubuntu 14.04)

Alias /SOGo.woa/WebServerResources/ \
/usr/lib/GNUstep/SOGo/WebServerResources/
Alias /SOGo/WebServerResources/ \
/usr/lib/GNUstep/SOGo/WebServerResources/
AliasMatch /SOGo/so/ControlPanel/Products/(.*)/Resources/(.*) \
/usr/lib/GNUstep/SOGo/$1.SOGo/Resources/$2

<Directory /usr/lib/GNUstep/SOGo/>
AllowOverride None
Require all granted
</Directory>

<LocationMatch
"^/SOGo/so/ControlPanel/Products/.*UI/Resources/.*\.(jpg|png|gif|css|js)">
SetHandler default-handler
</LocationMatch>

## Uncomment the following to enable proxy-side authentication, you will
then
## need to set the "SOGoTrustProxyAuthentication" SOGo user default to
YES and
## adjust the "x-webobjects-remote-user" proxy header in the "Proxy" section
## below.
#<Location /SOGo>
# AuthType XXX
# Require valid-user
# SetEnv proxy-nokeepalive 1
# Allow from all
#</Location>

ProxyRequests Off
SetEnv proxy-nokeepalive 1
ProxyPreserveHost On

# When using CAS, you should uncomment this and install
cas-proxy-validate.py
# in /usr/lib/cgi-bin to reduce server overloading
#
# ProxyPass /SOGo/casProxy http://localhost/cgi-bin/cas-proxy-validate.py
# <Proxy http://localhost/app/cas-proxy-validate.py>
# Order deny,allow
# Allow from your-cas-host-addr
# </Proxy>

ProxyPass /SOGo http://127.0.0.1:20000/SOGo retry=0

<Proxy http://127.0.0.1:20000/SOGo>
## adjust the following to your configuration
RequestHeader set "x-webobjects-server-port" "80"
RequestHeader set "x-webobjects-server-name" "sogo.mydomain.com"
RequestHeader set "x-webobjects-server-url" "http://sogo.mydomain.com";

## When using proxy-side autentication, you need to uncomment and
## adjust the following line:
# RequestHeader set "x-webobjects-remote-user" "%{REMOTE_USER}e"

RequestHeader set "x-webobjects-server-protocol" "HTTP/1.0"
RequestHeader set "x-webobjects-remote-host" %{REMOTE_HOST}e
env=REMOTE_HOST

AddDefaultCharset UTF-8

Order allow,deny
Allow from all
</Proxy>

## We use mod_rewrite to pass remote address to the SOGo proxy.
# The remote address will appear in SOGo's log files and in the X-Forward
# header of emails.
RewriteEngine On
RewriteRule ^/SOGo/(.*)$ /SOGo/$1 [env=REMOTE_HOST:%{REMOTE_ADDR},PT]

I am pretty sure it is proxy related, but I am at a loss at this point.
Any help is welcome.
Thanks,

Dominique

---
This email is free from viruses and malware because avast! Antivirus
protection is active.
http://www.avast.com



  • [SOGo] Mixup with proxy setup - Service Temporarily Unavailable, Dominique, 07/29/2014

Archive powered by MHonArc 2.6.18.

Top of page