General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] problem with ZEG script from onlinedomo.hu


Chronological Thread 
  • From: Szládovics Péter < >
  • To:
  • Subject: Re: [SOGo] problem with ZEG script from onlinedomo.hu
  • Date: Mon, 22 Sep 2014 12:39:21 +0200

Hi,

Check your /etc/apache2/mods-enabled directory:
Does it have authnz_ldap.load symlink?

If doesn't then you need to load it:

a2enmod authnz_ldap
service apache2 restart

If does, you haven't need to do anything, that error was just in the middle of the installation process.

Üdvözlettel,

Szládovics Péter
informatikus mérnök

Mobil: +36 20 9268098
Onlinedemo.HU



2014-09-22 11:45 keltezéssel, Systeembeheer írta:

That solved my problem. Now I have the next one:

 

Part 14:

Syntax error on line 53 of /etc/apache2/conf.d/phpldapadmin:

Unknown Authn provider: ldap

Action ‘configtest’ failed.

The Apache error log may have more information.

     …fail!

 

The file /var/log/apache2/error.log has nothing but messages from shutting down and  resuming normal operations.

 

Thanks in advance.

 

-Warner-

 

Van: [mailto: ] Namens Szládovics Péter
Verzonden: dinsdag 16 september 2014 13:03
Aan:
Onderwerp: Re: [SOGo] problem with ZEG script from onlinedomo.hu

 

2014-09-16 11:15 keltezéssel, Systeembeheer írta:

Hello,

I send the question to this mailing list as I cannot read Hungarian at all. (http://www.onlinedemo.hu/71-zeg-install-script)

 

The first problem occurs when you do the first reboot. Th system then statest that your current HWE is no longer supported.


It's no problem. You can upgrade the kernel (only the kernel) later.


I chose the second solution: sudo apt-get install linux-generic-lts-trusty linux-image-generic-lts-trusty

Is that a good choise?


It's the one choice.


The other solution is: sudo do-release-update  and that puts you in rev 14 and this is written for 12.04


No, you cannot upgrade the 12.04 LTS to 14.04, because the SOGo 14.04 repo's haven't ready yet.


Then at step 10 I get an error at the end:

Syntax error on line 10 of /etc/apache2/conf.d/SOGo.conf:

Invalid command ‘<IfVersion’ , perhaps misspelled or defined by a module not included in the server configuration.

Action ‘configtest’ failed.

The Apache error log may have more information.

    …fail!

 

What to do about this?


The older releases of SOGo not contained these rules. You need to load the right apache module (https://www.google.hu/search?client=ubuntu&channel=fs&q=apache+ifversion&ie=utf-8&oe=utf-8&gfe_rd=cr&ei=bxgYVLfcG6uI8QemqYHADg)

a2enmod version
service apache2 restart

And try again :)
I'll modify the script for solve this problem :)

Thanks your feedback.





Archive powered by MHonArc 2.6.18.

Top of page