General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Moving a SOGo installation to another server?


Chronological Thread 
  • From: Steve Ankeny < >
  • To:
  • Subject: Re: [SOGo] Moving a SOGo installation to another server?
  • Date: Sun, 28 Dec 2014 18:38:56 -0500

'sogo' is running (and has been)

HOWEVER, reviewing '/var/log/sogo/sogo.log1,' I believe I see the problem.

Initially, I had a difficulty creating 'sogo'@'localhost' in MySQL but 'sogo' created successfully.  That meant I was left with TWO users in MySQL both having access to SOGo, and 'sogo'@'localhost' took preference.

I found that it was clashing with 'sogo'@'localhost' and I could not grant ALL privileges, so dropped it.

In '/var/log/sogo/sogo.log.1,' I found the error . . .

2014-12-23 15:34:27.349 sogod[1839] ERROR: could not open MySQL4 connection to database 'sogo': Access denied for user 'sogo'@'localhost' (using password: YES)

And, it occurred to me that I had not restarted all services after dropping 'sogo'@'localhost' in MySQL

After a quick reboot, I found the following in '/var/log/sogo/sogo.log'

(NOT sogo.log1)

Dec 28 18:18:11 sogod [2035]: |SOGo| table 'sogo_user_profile' successfully created!
Dec 28 18:18:12 sogod [2035]: <0x0x7f9858b33358[GCSSessionsFolder]> sessions folder table 'sogo_sessions_folder' successfully created!
Dec 28 18:18:12 sogod [2034]: |SOGo| table 'sogo_folder_info' successfully created!

So, I am convinced at this point that user 'sogo' is now opening the channel with MySQL

I should now be able to do 'sogo-tool restore -f ALL output-directory username' . . .

HOWEVER, I still find an error when logging into the web interface . . .

2014-12-28 18:20:36.850 sogod[2034] Note: Using UTF-8 as URL encoding in NGExtensions.
192.168.121.179 - - [28/Dec/2014:18:20:36 GMT] "POST /SOGo/connect HTTP/1.1" 200 27/45 0.339 - - 1M
192.168.121.179 - - [28/Dec/2014:18:20:36 GMT] "GET /SOGo/steve HTTP/1.1" 302 0/0 0.007 - - 16K
192.168.121.179 - - [28/Dec/2014:18:20:37 GMT] "GET /SOGo/steve/view HTTP/1.1" 302 0/0 0.028 - - 0
192.168.121.179 - - [28/Dec/2014:18:20:37 GMT] "GET /SOGo/so/steve/Mail HTTP/1.1" 302 0/0 0.006 - - 0
2014-12-28 18:20:37.317 sogod[2034] WARNING: IMAP4 connection pooling is disabled!
Dec 28 18:20:37 sogod [2034]: [ERROR] <0x0x7f9859332958[NGImap4ConnectionManager]> IMAP4 login failed:

IMAP4 connection pooling is disabled and IMAP4 login failed

I'll need to review my IMAP settings (Postfix, Dovecot -- Dovecot appears to be connecting/creating)

All of this is prelude to syncing the IMAP folders of my "old" server with the "new"

Thanks, Ludovic for the quick response, and thanks for prompting me to think!

On 12/28/2014 05:47 PM, Ludovic Marcotte wrote:
On 28/12/2014 17:43, wrote:
Am I to create such a table in MySQL by the name, "sogo_folder_info?"

The first time you start SOGo, it'll create it.





Archive powered by MHonArc 2.6.18.

Top of page