General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Re: SOGo upgrade issue


Chronological Thread 
  • From: Steve Ankeny < >
  • To:
  • Subject: Re: [SOGo] Re: SOGo upgrade issue
  • Date: Wed, 24 Jun 2015 08:19:39 -0400

On 06/23/2015 10:04 AM, Ludovic Marcotte wrote:
You probably need to remove *all* Samba packages from 14.04 before installing our packages.

ok, started here --

adam@sogo:~$ sudo apt-get purge samba

The following extra packages will be installed:
  libgnutls28 libhogweed2 libldb-dev libldb1 libnettle4 libsmbclient
  python-ldb python-samba samba-common samba-common-bin samba-dev
  samba-dsdb-modules samba-libs samba-vfs-modules smbclient
Suggested packages:
  gnutls-bin heimdal-clients
The following packages will be REMOVED:
  libnss-winbind* libpam-winbind* openchangeproxy* openchangeserver* samba*
  winbind*
The following NEW packages will be installed:
  libgnutls28 libhogweed2 libnettle4
The following packages will be upgraded:
  libldb-dev libldb1 libsmbclient python-ldb python-samba samba-common
  samba-common-bin samba-dev samba-dsdb-modules samba-libs samba-vfs-modules
  smbclient
12 upgraded, 3 newly installed, 6 to remove and 8 not upgraded.

Removing libnss-winbind:amd64 (2:4.1.6+dfsg-1ubuntu2.14.04.7) ...
Removing libpam-winbind:amd64 (2:4.1.6+dfsg-1ubuntu2.14.04.7) ...
Removing openchangeserver (1:2.2-5) ...
Purging configuration files for openchangeserver (1:2.2-5) ...
Removing openchangeproxy (1:2.2-5) ...
Removing winbind (2:4.1.6+dfsg-1ubuntu2.14.04.7) ...
Purging configuration files for winbind (2:4.1.6+dfsg-1ubuntu2.14.04.7) ...
Removing samba (2:4.1.6+dfsg-1ubuntu2.14.04.7) ...
samba-ad-dc stop/waiting
nmbd stop/waiting
Purging configuration files for samba (2:4.1.6+dfsg-1ubuntu2.14.04.7) ...

[ it allowed me to keep my current 'smb.conf' ]

Setting up libnettle4:amd64 (2.7.1-1) ...
Setting up libhogweed2:amd64 (2.7.1-1) ...
Setting up libgnutls28:amd64 (3.2.11-2ubuntu1.1) ...
Setting up libldb1:amd64 (2:1.1.17-2) ...
Setting up samba-libs:amd64 (2:4.1.18+dfsg-3~inverse1) ...
Setting up samba-dsdb-modules (2:4.1.18+dfsg-3~inverse1) ...
Setting up python-ldb (2:1.1.17-2) ...
Setting up python-samba (2:4.1.18+dfsg-3~inverse1) ...
Setting up samba-common (2:4.1.18+dfsg-3~inverse1) ...
Setting up samba-common-bin (2:4.1.18+dfsg-3~inverse1) ...
Setting up libsmbclient:amd64 (2:4.1.18+dfsg-3~inverse1) ...
Setting up smbclient (2:4.1.18+dfsg-3~inverse1) ...
Setting up samba-vfs-modules (2:4.1.18+dfsg-3~inverse1) ...
Setting up libldb-dev (2:1.1.17-2) ...
Setting up samba-dev (2:4.1.18+dfsg-3~inverse1) ...

[ after which I ran 'sudo apt-get upgrade' again ]

The following packages have been kept back:
  python-ocsmanager
The following packages will be upgraded:
  libmapi0 libmapiproxy0 libmapistore0 libwbclient0 sogo sogo-activesync
  sogo-openchange
7 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

[ here's where it failed to resolve the Inverse repositories ]

Err http://inverse.ca/ubuntu/ trusty/trusty libmapi0 amd64 3:2.3-zentyal11
  Could not resolve 'inverse.ca'
. . . . . . .
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

[ and, 'sudo apt-get update' failed to resolve Inverse.ca ]


I suspect that's caused by DNS pointing to Samba-AD-DC which no longer existed.

I'll try again overnight once I determine how I'll change DNS





Archive powered by MHonArc 2.6.18.

Top of page