General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] ANN: SOGo v3.0 beta 1


Chronological Thread 
  • From: Steve Ankeny < >
  • To:
  • Subject: Re: [SOGo] ANN: SOGo v3.0 beta 1
  • Date: Mon, 21 Sep 2015 07:11:03 -0400

On 08/31/2015 03:51 PM, Ludovic Marcotte wrote:
Hello,

After many months of development, Inverse is happy to announce the availability of SOGo v3.0 beta 1.


ran "update|upgrade" successfully ('sope', 'sogo', 'openchange-ocsmanager', etc.)

after running update a second time, I saw the following --

The following packages have been kept back:
  openchangeproxy openchangeserver

so, I ran the following --

adam@sogo:~$ sudo apt-get install openchangeproxy openchangeserver
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following extra packages will be installed:
  libnanomsg0 python-memcache
The following NEW packages will be installed:
  libnanomsg0 python-memcache
The following packages will be upgraded:
  openchangeproxy openchangeserver
2 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,008 kB of archives.
After this operation, 646 kB of additional disk space will be used.
Do you want to continue? [Y/n]

once I chose Y, I received the following error --

=== OpenChange Directory ===
schema_data_add: updates are not allowed: reject request

THAT was because I had the following in my 'smb.conf' --

    ### Configuration required by OpenChange server ###
    #dsb:schema update allowed = true
    #dcerpc endpoint servers = +epmapper, +mapiproxy
    #dcerpc_mapiproxy:server = true
    #dcerpc_mapiproxy:interfaces = exchange_emsmdb, exchange_nsp, exchange_ds_rfr
    ### Configuration required by OpenChange server ###

so, once I removed # from 'dsb:schema update allowed = true' and restarted 'samba-ad-dc' --

ran 'sudo apt-get remove libnanomsg0 python-memcache'

and, of course, it removed 'openchangeproxy openchangeserver' as well

I can install/upgrade all four packages but I get the following --

=== OpenChange Directory ===
Nothing to migrate

Do I need to simply reprovision OpenChange?

the database is still intact in MySQL

thx

ADDENDUM --

I'm thinking not having these two packages ('libnanomsg0' and 'python-memcache') was the reason every time I tried to call DCERPC services from 'smb.conf', it "shut down" my Samba-AD-DC (which was NOT solved)

https://lists.inverse.ca/sogo/arc/users/2015-07/msg00257.html

I'm still not able to call 'dcerpc' services from 'smb.conf' and OpenChange is not running properly.





Archive powered by MHonArc 2.6.18.

Top of page