General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] ANN: SOGo v3.0 beta 1


Chronological Thread 
  • From: Christian Mack < >
  • To:
  • Subject: Re: [SOGo] ANN: SOGo v3.0 beta 1
  • Date: Wed, 23 Sep 2015 09:32:06 +0200

Am 22.09.2015 um 14:47 schrieb Steve Ankeny:
> On 09/21/2015 07:11 AM, Steve Ankeny wrote:
>> On 08/31/2015 03:51 PM, Ludovic Marcotte wrote:
>>> Hello,
>>>
>>> After many months of development, Inverse is happy to announce the
>>> availability of SOGo v3.0 beta 1.
>>
>>
>> ran "update|upgrade" successfully ('sope', 'sogo',
>> 'openchange-ocsmanager', etc.)
>>
>> after running update a second time, I saw the following --
>>
>> The following packages have been kept back:
>> openchangeproxy openchangeserver
>>
>> so, I ran the following --
>>
>> adam@sogo:~$ sudo apt-get install openchangeproxy openchangeserver
>> Reading package lists... Done
>> Building dependency tree
>> Reading state information... Done
>> The following extra packages will be installed:
>> libnanomsg0 python-memcache
>> The following NEW packages will be installed:
>> libnanomsg0 python-memcache
>> The following packages will be upgraded:
>> openchangeproxy openchangeserver
>> 2 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
>> Need to get 1,008 kB of archives.
>> After this operation, 646 kB of additional disk space will be used.
>> Do you want to continue? [Y/n]
>>
>> once I chose Y, I received the following error --
>>
>> === OpenChange Directory ===
>> schema_data_add: updates are not allowed: reject request
>>
>> THAT was because I had the following in my 'smb.conf' --
>>
>> ### Configuration required by OpenChange server ###
>> #dsb:schema update allowed = true
>> #dcerpc endpoint servers = +epmapper, +mapiproxy
>> #dcerpc_mapiproxy:server = true
>> #dcerpc_mapiproxy:interfaces = exchange_emsmdb, exchange_nsp,
>> exchange_ds_rfr
>> ### Configuration required by OpenChange server ###
>>
>
> BEFORE I uncommented 'dsb:scheme update allowed = true' I saw the
> following --
>
> === OpenChange Directory ===
> schema_data_add: updates are not allowed: reject request
>
> Error adding msExchRecipientTypeDetails and msExchRecipientDisplayType
> atributes to schema: (53, 'schema_data_add: updates are not allowed:
> reject request\n')
> Unable to find attribute msExchRecipientDisplayType in the schema
> Error adding msExchRecipientTypeDetails and msExchRecipientDisplayType
> to Mail-Recipient schema: (21, "objectclass_attrs: attribute
> 'mayContain' on entry
> 'CN=Mail-Recipient,CN=Schema,CN=Configuration,DC=smbdomain,DC=com'
> contains at least one invalid value!")
> Error migrating user CN=cbsexports,CN=Users,DC=smbdomain,DC=com: (16,
> "objectclass_attrs: attribute 'msExchRecipientTypeDetails' on entry
> 'CN=cbsexports,CN=Users,DC=smbdomain,DC=com' was not found in the
> schema!"). Skipping user
> Error migrating user CN=cbsexports,CN=Users,DC=smbdomain,DC=com: (16,
> "objectclass_attrs: attribute 'msExchRecipientDisplayType' on entry
> 'CN=cbsexports,CN=Users,DC=smbdomain,DC=com' was not found in the
> schema!"). Skipping user
> Error migrating user CN=steve,CN=Users,DC=smbdomain,DC=com: (16,
> "objectclass_attrs: attribute 'msExchRecipientTypeDetails' on entry
> 'CN=steve,CN=Users,DC=smbdomain,DC=com' was not found in the schema!").
> Skipping user
> Error migrating user CN=steve,CN=Users,DC=smbdomain,DC=com: (16,
> "objectclass_attrs: attribute 'msExchRecipientDisplayType' on entry
> 'CN=steve,CN=Users,DC=smbdomain,DC=com' was not found in the schema!").
> Skipping user
>
> [listing each user in the database and ending with "Skipping user"]
>
> Migration of openchange directory done
> === OpenChange DB ===
> Migration openchange db done
> === Indexing ===
> Nothing to migrate
> === Named Properties ===
> Migration MAPIStore named properties backend done
> Processing triggers for libc-bin (2.19-0ubuntu6.6) ...
> adam@sogo:~$
>
>
> It appears there WAS data to migrate BEFORE the error, and it's still in
> the database.
>
> THAT's why I ask the question --
>
>>
>> *Do I need to simply reprovision OpenChange?
>>
>> *I'm still not able to call 'dcerpc' services from 'smb.conf' and
>> OpenChange is not running properly.
>>
>>
>

Looks for me, like your SAMBA4 was not Schema master when you upgraded.
This should be checked in the upgrade script if needed.
Therefore you should open a bug report at http://www.sogo.nu/bugs


Kind regards,
Christian Mack

--
Christian Mack
Universität Konstanz
Kommunikations-, Informations-, Medienzentrum (KIM)
Abteilung Basisdienste
78457 Konstanz
+49 7531 88-4416

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature




Archive powered by MHonArc 2.6.18.

Top of page