General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] How do I know which update script I have to call?


Chronological Thread 
  • From: "Steve Ankeny" ( ) < >
  • To:
  • Subject: Re: [SOGo] How do I know which update script I have to call?
  • Date: Sat, 30 Apr 2016 12:02:31 -0400
  • Dmarc-filter: OpenDMARC Filter v1.2.0 mail.inverse.ca E90B8EC235E

hmm

You stated originally --

For example: I just
updated and I'm now on 2.3.1. I don't know if I have to call the script
"sql-update-2.2.17_to_2.3.0-mysql.sh".

So, that means you were on v. 2.3.0 and shouldn't need the upgrade script.

The update script upgrades from 2.2.17 to 2.3.0, so IF you were on 2.3.0, you do not need the script.

However, check "/etc/sogo/sogo.conf" for the lines --


SOGoProfileURL = "postgresql://sogo:sogo@localhost:5432/sogo/sogo_user_profile"; OCSFolderInfoURL = "postgresql://sogo:sogo@localhost:5432/sogo/sogo_folder_info"; OCSSessionsFolderURL = "postgresql://sogo:sogo@localhost:5432/sogo/sogo_sessions_folder";

Yours probably read --


SOGoProfileURL = "mysql://sogo:sogo@localhost:3306/sogo/sogo_user_profile"; OCSFolderInfoURL = "mysql://sogo:sogo@localhost:3306/sogo/sogo_folder_info"; OCSSessionsFolderURL = "mysql://sogo:sogo@localhost:3306/sogo/sogo_sessions_folder";

That would tell you to call the "sql-update-2.2.17_to_2.3.0-mysql.sh" script, and as I stated earlier, it does not harm the installation for you to call it AGAIN (IF you're unsure or IF something doesn't work correctly)

So, no update script is required, but IF you're unsure or IF something doesn't work, call the MySQL script.

On 04/30/2016 09:27 AM, Michael Vogel ( ) wrote:
Am 29.04.16 um 16:21 schrieb Steve Ankeny (
 ):
read pg 58-59 of the documentation
It only tells:

"This section describes what needs to be done when upgrading to the
current version of SOGo from the previous release."

For example: When I'm not totally sure that my previous version was
version 2.3.0 and not 2.2.8 then I don't have a clue if I have to call
the script or not.

If it was working before upgrade, no script is needed.
Is it called automatically during the upgrade or why wouldn't the script
beeing needed in that case?

Michael





Archive powered by MHonArc 2.6.18.

Top of page