General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] ANN: SOGo Package Repositories


Chronological Thread 
  • From: "Jan Skarvall" ( ) < >
  • To:
  • Subject: Re: [SOGo] ANN: SOGo Package Repositories
  • Date: Sat, 23 Jul 2016 13:45:15 +0200
  • Dmarc-filter: OpenDMARC Filter v1.2.0 mail.inverse.ca B2E07C0201A

Ahh, found it in https://packages.inverse.ca/SOGo/nightly/2/ubuntu/pool/trusty/w/wbxml2/ :-)


On 2016-07-23 13:02, Jan Skarvall wrote:

I am trying to recreate SOGo-2.3.8 (and SOPE-2.3.8) for Ubuntu 14.04 (trusty), following the description below.

When running dpkg-buildpackage -b in SOGo-2.3.8 I got stuck on "dpkg-checkbuilddeps: Unmet build dependencies: libwbxml2-dev (>= 0.11.2)", and when looking in https://packages.inverse.ca/SOGo/nightly/2/debian/pool/trusty/ I find to my surprise that there are no files there.

trusty itself installs libwbxml2-dev 0.10.7-1.

$ dpkg -l | grep libwbxml2-dev
ii  libwbxml2-dev                       0.10.7-1                             amd64        WBXML library development file

Now I am unsure how to get past this.


On 2016-07-19 22:45, Achim Gottinger ( ) wrote:
Here is an short howto for sogo2 on wheezy without openchange

First download SOPE-3.1.4.tar.gz and SOGo-2.3.13.tar.gz install build-essentails and dpkg-dev
On wheezy libwbxml2 is also required you can get the required version https://packages.inverse.ca/SOGo/nightly/2/debian/pool/wheezy/w/wbxml2/

# tar xvzf SOPE-3.1.4.tar.gz
#  cd SOPE
#  cp -a packaging/debian .
#  ./debian/rules
# dpkg-buildpackage
(install all required dependencies)
# dpkg-buildpackage
# cd ..
# dpkg -i libsope*.deb
# tar xvzf SOGo-2.3.13.tar.gz
# cd SOGo-2.3.13
#  ./debian/rules
# dch
(add an changelog entry for version 2.3.13)
 dpkg-buildpackage -b
(install all required dependencies)
# dpkg-buildpackage -b

You should now have build these packages:

libsbjson2.3_4.9.r1664_amd64.deb
libsbjson2.3-dev_4.9.r1664_amd64.deb
libsope4.9-dev_4.9.r1664_all.deb
libsope-appserver4.9_4.9.r1664_amd64.deb
libsope-appserver4.9-dev_4.9.r1664_amd64.deb
libsope-core4.9_4.9.r1664_amd64.deb
libsope-core4.9-dev_4.9.r1664_amd64.deb
libsope-gdl1-4.9_4.9.r1664_amd64.deb
libsope-gdl1-4.9-dev_4.9.r1664_amd64.deb
libsope-ldap4.9_4.9.r1664_amd64.deb
libsope-ldap4.9-dev_4.9.r1664_amd64.deb
libsope-mime4.9_4.9.r1664_amd64.deb
libsope-mime4.9-dev_4.9.r1664_amd64.deb
libsope-xml4.9_4.9.r1664_amd64.deb
libsope-xml4.9-dev_4.9.r1664_amd64.deb
sogo_2.3.13_amd64.deb
sogo-activesync_2.3.13_amd64.deb
sogo-dbg_2.3.13_amd64.deb
sogo-dev_2.3.13_amd64.deb
sope4.9-appserver_4.9.r1664_amd64.deb
sope4.9-dbg_4.9.r1664_amd64.deb
sope4.9-gdl1-mysql_4.9.r1664_amd64.deb
sope4.9-gdl1-postgresql_4.9.r1664_amd64.deb
sope4.9-libxmlsaxdriver_4.9.r1664_amd64.deb
sope4.9-stxsaxdriver_4.9.r1664_amd64.deb


But i have not yet tested if these packages work proper. :-)


Am 19.07.2016 um 21:31 schrieb Heiner Markert ( ):
Hello,

could you please post a short howto on how to build those debian packages based on the control files?

Thanks and best regards
Heiner



Am 19.07.2016 um 21:11 schrieb Achim Gottinger ( ):


Am 19.07.2016 um 20:10 schrieb Ludovic Marcotte ( ):

On 2016-07-19 12:35 PM, "Kai-Uwe Rommel" ( ) wrote:

What does that mean for me? I have to download the source code and
compile myself? Or should use nightly builds? How do I access
these? Are these also in a package repository available to me?
How are these accessed?
Nightly builds are indeed available - just like before: https://sogo.nu/download.html

There are FAQs on how to configure your repos for Yum and apt-get.

Generating packages from the SOGo/SOPE sources isn't complex - it's just like building any other packages. We still provide the Debian control files and the spec files to do so.

Thanks!
Thank you for the clarification. Managed to build debian wheezy packages for sope and sogo with control files under packaging/debian.
--

https://inverse.ca/sogo/lists

--

https://inverse.ca/sogo/lists
--

https://inverse.ca/sogo/lists




Archive powered by MHonArc 2.6.18.

Top of page