General discussion on installation and configuration of SOGo

Text archives Help

Re: [SOGo] Apt-get upgrade after SOGo compilation

Chronological Thread 
  • From: Slávek Banko ( ) < >
  • To:
  • Subject: Re: [SOGo] Apt-get upgrade after SOGo compilation
  • Date: Tue, 27 Sep 2016 19:30:50 +0200
  • Dmarc-filter: OpenDMARC Filter v1.2.0 54C5C11E210C

Dne po 26. září 2016 Louis-Philippe napsal(a):
> Hi,
> We compiled SOGo and SOPE on Debian Jessie. Everything works fine
> except the following point.
> When we do an "apt-get upgrade", we have always this error:
> The following packages have unmet dependencies:
> sogo : Depends: libsbjson2.3 (>= 4.9.r1664.20160708) but 4.9.r1664 is
> installed
> E: Unmet dependencies. Try using -f.
> If we do an "apt-get -f install", it wants to uninstall SOGo...
> Do you have an idea to remove this warning ?
> Thanks,
> --
> Louis-Philippe

When you create packages yourself, you have to establish rules for
composing package versions. Otherwise, the update will not work

For packages SOGo itself it seems simple => you can use the version number
of the SOGo release. However, there can also be problems - for example,
official packages from Inverse have problems during the dist-upgrade.

But packages SOPE are always released just as the current snapshot ==
without clear version number. Therefore use only 4.9.r1664 as version
number is insufficient. The number 4.9 seems clear. But the following
r1664 is totally misleading. This is determined as a historical snapshot
of the previously used Monotone. For the current versions, this number
has no useful value.

For SOPE packages therefore you need to have your own rules. For example,
in official packages from Inverse is added current date of snapshot to
the version number.

By the way, if you want to use a stable releases but do not want to
compile yourself, you can use the alternative apt repository, which I
have previously provided.


Archive powered by MHonArc 2.6.18.

Top of page