General discussion on installation and configuration of SOGo

Text archives Help


[SOGo] Re. SOGo not sending scripts to managesieve


Chronological Thread 
  • From: "Andreas" ( ) < >
  • To:
  • Subject: [SOGo] Re. SOGo not sending scripts to managesieve
  • Date: Fri, 21 Oct 2016 21:38:56 +0200
  • Dmarc-filter: OpenDMARC Filter v1.2.0 mail.inverse.ca 89DC0EECB8C


Hi Oliver,

I am facing the same problem. Did you find a solution in the meantime?


Regards,

Andreas




Hello Christian,

thanks for your reply.
The only setting that was different from yours it the MailSpoolPath. I
adapted it, but nothing changed.
I also created the script /var/vmail/.../sieve/sogo.sieve as well as the
link /var/vmail/.../.sieve pointing to the sogo script. But as before,
when I modify the filter rules in the SOGo web interface and save the
changes, SOGo tells managesieve the command 'SETACTIVE ""' which deletes
the link /var/vmail/.../.sieve and furthermore 'DELETESCRIPT "sogo"'
which removes the file /var/vmail/.../sieve/sogo.sieve. But then SOGo
doesn't sends any further instructions to create a new sogo script and
to reenable it.
I'm not using any other software than SOGo to modify my sieve scripts.

Oliver


------ Originalnachricht ------
Von: "Christian Eichert" <
>
An:

Gesendet: 28.06.2016 13:51:11
Betreff: Re: [SOGo] SOGo not sending scripts to managesieve

Hallo to allerseits
I had a similar problem about a long time ago when I first implemented
SOGo
there the following settings in /etc/sogo/sogo.conf that are relevant
with sieve
SOGoMailSpoolPath = /var/vmail;
[...]
SOGoSieveServer = "sieve://mail.mydomain.org:4190";
SOGoSieveScriptsEnabled = YES; // (Sieve Script einschalten)
SOGoVacationEnabled = YES;
SOGoForwardEnabled = YES;
this will result that for example in this described case sogo expects

to have a folder called
/var/vmail/
/sieve/

and in it a file called :
/var/vmail/
/sieve/sogo.sieve
The first thing to remember is that
1) YOU MUST CREAT IT. SOGo will not create this file for you. And you
must call it sogo.sieve. No other name is good.
And you have to place the link from
ln /var/vmail/
/sieve/sogo.sieve
/var/vmail/
/.dovecot.sieve
for dovecot to know this is the main sieve script. SOGo will not put the
link.
For some reason this file (/var/vmail/
/sieve/sogo.sieve)
is not read correctly by SOGo.
If you create it and modify it with SOGo the world looks fine, but you
must never touch this script with another editor.
2) If you modify this file for example with the Thunderbird app SOGO
will ignore the changing and will overwrite it with the last version you
created with SOGo next time.
Also SOGo does not allow one to write the sieve script by hand.
The Thunderbird plugin will let you create a huge number of scripts, but
you can always activate only one.
The script you create with Thunderbird will be called main.sieve and if
you activate it your script you created with SOGo will not be active.
And probably this is happening with your case.
Have Fun
Christian

On 27.06.2016 21:56,

wrote:
Hi Tilo,

thanks for your response. For me it's:

plugin {
sieve = /var/vmail/%d/%n/.sieve
sieve_dir = /var/vmail/%d/%n/sieve
sieve_before = /var/vmail/sieve/spam-global.sieve
}

As managesieve does not throw any error despite from the non-existant
sogo script, I suppose, the fault is located on the sogo side and
dovecot is configured correctly.
Is somone else using SOGo 3.1.x on Ubuntu 16.04 with dovecot 2.2.22?

Oliver


------ Originalnachricht ------
Von: "Tilo Werner" mailto:


An:


Gesendet: 27.06.2016 12:43:54
Betreff: Re: [SOGo] SOGo not sending scripts to managesieve

Hi,

for dovecot I've got:

plugin {
sieve = /var/vmail/%d/%n/.dovecot.sieve
sieve_dir = /var/vmail/%d/%n/.sieve
sieve_before = /etc/dovecot/sieve.before
}

where .dovecot.sieve is a link to the active sieve script in folder
.sieve

ls -la /var/vmail/moosbee.de/tilo/.dovecot.sieve -> .sieve/sogo.sieve

The active script is defined by the link target.

Hope that helps.
Tilo

Am 27.06.2016 um 00:23 schrieb
:

Hello everybody,

I'm having problems with my fresh SOGo 3.1.3 installation on Ubuntu
16.04 with dovecot: when I modify email filters, SOGo does not send
sieve scripts to managesieve. I tracked the TCP traffic to the
managesieve server:

# tcpflow -c -i lo port 4190
tcpflow: listening on lo
127.000.000.001.04190-127.000.000.001.56344: "IMPLEMENTATION" "Dovecot
Pigeonhole"
"SIEVE" "fileinto reject envelope encoded-character vacation
subaddress comparator-i;ascii-numeric relational regex imap4flags copy
include variables body enotify environment mailbox date index ihave
duplicate mime foreverypart extracttext"
"NOTIFY" "mailto"
"SASL" "PLAIN LOGIN"
"STARTTLS"
"VERSION" "1.0"
OK "Dovecot ready."

127.000.000.001.56344-127.000.000.001.04190: AUTHENTICATE "PLAIN"
{100+}
[...]
127.000.000.001.56344-127.000.000.001.04190:

127.000.000.001.04190-127.000.000.001.56344: OK "Logged in."

127.000.000.001.04190-127.000.000.001.56346: "IMPLEMENTATION" "Dovecot
Pigeonhole"
"SIEVE" "fileinto reject envelope encoded-character vacation
subaddress comparator-i;ascii-numeric relational regex imap4flags copy
include variables body enotify environment mailbox date index ihave
duplicate mime foreverypart extracttext"
"NOTIFY" "mailto"
"SASL" "PLAIN LOGIN"
"STARTTLS"
"VERSION" "1.0"
OK "Dovecot ready."

127.000.000.001.56346-127.000.000.001.04190: AUTHENTICATE "PLAIN"
{100+}
[...]
127.000.000.001.56346-127.000.000.001.04190:

127.000.000.001.04190-127.000.000.001.56346: OK "Logged in."

127.000.000.001.56346-127.000.000.001.04190: SETACTIVE ""
127.000.000.001.56346-127.000.000.001.04190:

127.000.000.001.04190-127.000.000.001.56346: OK "No scripts currently
active."

127.000.000.001.56346-127.000.000.001.04190: DELETESCRIPT "sogo"
127.000.000.001.56346-127.000.000.001.04190:

127.000.000.001.04190-127.000.000.001.56346: NO (NONEXISTENT) "Sieve
script `sogo' not found"

Here the tcp flow ends. No more communication between SOGo and the
managesieve server.

/var/log/sogo/sogo.log:
Jun 26 23:45:14 sogod [11583]: [ERROR]
<0x55580dc3f5c0[SOGoAppointmentInboxFolder]:inbox> (-[SOGoGCSFolder
toOneRelationshipKeys]): fetch failed!
Jun 26 23:45:14 sogod [11583]: <IP> "PROPFIND
/dav/oliver/Calendar/inbox/ HTTP/1.1" 207 333/128 0.069 - - 0
Jun 26 23:49:35 sogod [11583]: <IP> "GET /so/oliver/Preferences
HTTP/1.1" 200 22307/0 0.116 97847 77% 192K
Jun 26 23:49:36 sogod [11585]: <IP> "GET /so/oliver/jsonSettings
HTTP/1.1" 200 1353/0 0.007 - - 0
Jun 26 23:49:36 sogod [11584]: <IP> "GET /so/oliver/jsonDefaults
HTTP/1.1" 200 4031/0 0.016 - - 0
Jun 26 23:49:36 sogod [11583]: <IP> "GET
/so/oliver/Calendar/alarmslist?browserTime=1466977768 HTTP/1.1" 200
389/0 0.033 - - 0
Jun 26 23:49:36 sogod [11583]: <IP> "GET /so/oliver/Mail/0/view
HTTP/1.1" 200 5065/0 0.283 - - 0
Jun 26 23:49:41 sogod [11583]: <IP> "GET
/so/oliver/editFilter?filter=new HTTP/1.1" 200 1780/0 0.008 7536 76% 0
Jun 26 23:49:53 sogod [11583]: <0x0x55580dc5dc10[SOGoSieveManager]>
WARNING: Could not delete Sieve script - continuing...: {RawResponse =
"{ok = 0; }"; result = 0; }
Jun 26 23:49:53 sogod [11583]: <IP> "POST /so/oliver/Preferences/save
HTTP/1.1" 200 0/5193 0.260 - - 0

In /var/log/mail.err and /var/log/mail.log there are no abnormal
entries.
If I create a file named sogo.sieve in the sieve directory, then the
managesieve server returns a positive answer to the delete command of
SOGo, but SOGO doesn't send more commands either.
I at first had installed SOGo version 3.1.2, where the error was
already
present. I then did the update in the hope of resolving the problem.
What am I missing?

Thanks.

Oliver
--



https://inverse.ca/sogo/lists


  • [SOGo] Re. SOGo not sending scripts to managesieve, Andreas, 10/21/2016

Archive powered by MHonArc 2.6.18.

Top of page