General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Issue with Sieve server connection


Chronological Thread 
  • From: "Andreas Oster" ( ) < >
  • To:
  • Subject: Re: [SOGo] Issue with Sieve server connection
  • Date: Thu, 13 Jul 2017 13:44:41 +0200
  • Dmarc-filter: OpenDMARC Filter v1.2.0 mail.inverse.ca 71AAEF04B5B

Am 12.07.2017 um 17:02 schrieb Christian Mack ( ):
Am 12.07.2017 um 09:57 schrieb Andreas Oster
( ):
Am 11.07.2017 um 11:50 schrieb Christian Mack
( ):
Am 09.07.2017 um 10:34 schrieb Andreas Oster
( ):
Hi all,

I am currently using SOGo version 3.2.10 and have received some
complains from users that they are no longer able to create or edit mail
filters from the SOGo Web GUI. SOGo and the mail server are installed on
different machines. We use dovecot as our imap/s server with Pigeonhole
(4190 TLS) for the sieve server part.

We get some error messages in the sogo.log when a user tries to add/edit
a filter:

Jul 09 09:56:18 sogod [365]: <0x0x5559fd6dc350[SOGoCache]> Cache cleanup
interval set every 300.000000 seconds
Jul 09 09:56:18 sogod [365]: <0x0x5559fd6dc350[SOGoCache]> Using host(s)
'localhost' as server(s)
Jul 09 09:56:19 sogod [365]: 10.2.129.60 "POST
/SOGo/so/username/Mail/0/folderINBOX/expunge HTTP/1.1" 200 59/0 0.308 -
- 3M
Jul 09 09:56:19 sogod [365]: [WARN]
<0x0x5559fd846090[SOGoWebDAVAclManager]> entry '{DAV:}write' already
exists in DAV permissions table
Jul 09 09:56:19 sogod [365]: [WARN]
<0x0x5559fd846090[SOGoWebDAVAclManager]> entry '{DAV:}write-properties'
already exists in DAV permissions table
Jul 09 09:56:19 sogod [365]: [WARN]
<0x0x5559fd846090[SOGoWebDAVAclManager]> entry '{DAV:}write-content'
already exists in DAV permissions table
Jul 09 09:56:19 sogod [365]: 10.2.129.60 "GET
/SOGo/so/username/Calendar/alarmslist?browserTime=1499586985 HTTP/1.1"
200 145/0 0.009 - - 764K
Jul 09 09:56:20 sogod [365]: 10.2.129.60 "GET
/SOGo/so/username/Mail/0/view HTTP/1.1" 200 59692/0 0.532 - - 6M
Jul 09 09:56:25 sogod [365]: [WARN] <0x0x7fe38c138cc0[WOxElemBuilder]>
could not locate builders: WOxExtElemBuilder,WOxExtElemBuilder
Jul 09 09:56:25 sogod [365]: 10.2.129.60 "GET
/SOGo/so/username/editFilter?filter=7 HTTP/1.1" 200 1925/0 0.019 8047
76% -1620K
Jul 09 09:56:30 sogod [365]: <0x0x5559fdafcce0[NGSieveClient]> TLS
started successfully.
Jul 09 09:56:30 sogod [365]: <0x0x5559fdaf98f0[SOGoSieveManager]>
failure. Attempting with a renewed password (no authname supported)
Jul 09 09:56:30 sogod [365]: <0x0x5559fdafcce0[NGSieveClient]> TLS
started successfully.
Jul 09 09:56:30 sogod [365]: <0x0x5559fdaf98f0[SOGoSieveManager]> Could
not login 'username' on Sieve server: <0x0x5559fdafcce0[NGSieveClient]:
socket=<NGActiveSSLSocket[0x0x5559fdb13450]: mode=rw address=(null)>>:
{RawResponse = "{ok = 0; reason = \"Error in MANAGESIEVE command
received by server.\"; }"; result = 0; }
Jul 09 09:56:30 sogod [365]: 10.2.129.60 "POST
/SOGo/so/username/Preferences/save HTTP/1.1" 503 46/10661 0.302 - - 1M
Jul 09 09:59:25 sogod [365]: <0x0x5559fdbb2560[NGSieveClient]> TLS
started successfully.
Jul 09 09:59:25 sogod [365]: <0x0x5559fdba8ed0[SOGoSieveManager]>
failure. Attempting with a renewed password (no authname supported)
Jul 09 09:59:25 sogod [365]: <0x0x5559fdbb2560[NGSieveClient]> TLS
started successfully.
Jul 09 09:59:25 sogod [365]: <0x0x5559fdba8ed0[SOGoSieveManager]> Could
not login 'username' on Sieve server: <0x0x5559fdbb2560[NGSieveClient]:
socket=<NGActiveSSLSocket[0x0x5559fdbc6bc0]: mode=rw address=(null)>>:
{RawResponse = "{ok = 0; reason = \"Error in MANAGESIEVE command
received by server.\"; }"; result = 0; }
Jul 09 09:59:25 sogod [365]: 10.2.129.60 "POST
/SOGo/so/username/Preferences/save HTTP/1.1" 503 46/10509 0.275 - - 264K
Jul 09 10:00:19 sogod [365]: 10.2.1.80 "REPORT
/SOGo/dav/caladmin/Calendar/1F52-51E66500-19-4273B180/ HTTP/1.1" 207
125/188 0.113 - - 0



I have tried to access the sieve server with the following command:

gnutls-cli --starttls -p4190 mail.example.com

and had no problem to connect/login to the server.

Does someone have an idea what could be the issue and how to resolve
it ?


Do you use a master user in order to connect from SOGo to managesieve?


Kind regards,
Christian Mack

Hello Christian,

we do not use a master user, there should be individual logins for each
user trying to access the sieve server. I think that it might be
connected with a certificate change I recently had to do when the server
certificate had expired. Unfortunately I have no clue how to resolve
this issue.

best regards
Andreas


I do not think it is a certificate problem, because you get:
TLS started successfully.
That means your certificate is used correctly.

Which errors do you get from your dovecot/pidginhole error log?

For error message:
failure. Attempting with a renewed password (no authname supported)
another user on this list had a permission problem with her sieve
directories.
Fix was:
chown -R vmail:vmail /home/vmail/sieve
(Of course his command depends on your dovecot configuration!)


Kind regards,
Christian Mack


Hi all,

in a posting on the dovecot user list Stephan Bosch pointed out that there is already a fix:

https://github.com/dovecot/pigeonhole/commit /c80aa7c25b0b4e61bb8e3a91864a355f7f2fa89f

This small change also resolved my sieve login issue.

best regards
Andreas




Archive powered by MHonArc 2.6.18.

Top of page