General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] SOGo won't start after updates


Chronological Thread 
  • From: "Odhiambo Washington" ( ) < >
  • To:
  • Cc:
  • Subject: Re: [SOGo] SOGo won't start after updates
  • Date: Sat, 9 Mar 2019 16:39:31 +0300
  • Dmarc-filter: OpenDMARC Filter v1.2.0 mail.inverse.ca EE7661DE5088



On Sat, 9 Mar 2019 at 07:14, Alonso Cárdenas Márquez < > wrote:
El jue., 7 feb. 2019 a las 1:37, Odhiambo Washington (< >) escribió:
The output does not really help me figure it out:

root@waridi:/usr/home/wash # ldd /usr/local/GNUstep/Local/Tools/Admin/sogod
/usr/local/GNUstep/Local/Tools/Admin/sogod:
        libSOGo.so.4 => /usr/local/GNUstep/Local/Library/Libraries/sogo/libSOGo.so.4 (0x801000000)
        libGDLContentStore.so.4.9 => /usr/local/lib/compat/pkg/libGDLContentStore.so.4.9 (0x8011e5000)
        libGDLAccess.so.4.9 => /usr/local/lib/compat/pkg/libGDLAccess.so.4.9 (0x80143d000)
        libWEExtensions.so.4.9 => /usr/local/lib/compat/pkg/libWEExtensions.so.4.9 (0x801800000)
        libNGCards.so.4.9 => /usr/local/lib/compat/pkg/libNGCards.so.4.9 (0x801d36000)
        libNGObjWeb.so.4.9 => /usr/local/lib/compat/pkg/libNGObjWeb.so.4.9 (0x802000000)
        libNGMime.so.4.9 => /usr/local/lib/compat/pkg/libNGMime.so.4.9 (0x802c00000)
        libNGLdap.so.4.9 => /usr/local/lib/compat/pkg/libNGLdap.so.4.9 (0x80323b000)
        libNGStreams.so.4.9 => /usr/local/lib/compat/pkg/libNGStreams.so.4.9 (0x8034ad000)
        libNGExtensions.so.4.9 => /usr/local/lib/compat/pkg/libNGExtensions.so.4.9 (0x80380e000)
        libEOControl.so.4.9 => /usr/local/lib/compat/pkg/libEOControl.so.4.9 (0x803bdc000)
        libDOM.so.4.9 => /usr/local/lib/compat/pkg/libDOM.so.4.9 (0x803e8f000)
        libSaxObjC.so.4.9 => /usr/local/lib/compat/pkg/libSaxObjC.so.4.9 (0x80419d000)
        libSBJson.so.2 => /usr/local/GNUstep/Local/Library/Libraries/libSBJson.so.2 (0x80066b000)
        libgnustep-base.so.1.26 => /usr/local/GNUstep/System/Library/Libraries/libgnustep-base.so.1.26 (0x804400000)
        libobjc.so.4.6 => /usr/local/lib/libobjc.so.4.6 (0x804b0d000)
        libm.so.5 => /lib/libm.so.5 (0x804d3c000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x804f6b000)
        libthr.so.3 => /lib/libthr.so.3 (0x80517a000)
        libc.so.7 => /lib/libc.so.7 (0x800823000)
        libmemcached.so.11 => /usr/local/lib/libmemcached.so.11 (0x8053a2000)
        libcrypto.so.9 => /usr/local/lib/libcrypto.so.9 (0x805600000)
        libcrypt.so.5 => /lib/libcrypt.so.5 (0x805a7f000)
        libgnustep-base.so.1.25 => /usr/local/lib/compat/pkg/libgnustep-base.so.1.25 (0x805e00000)
        libldap-2.4.so.2 => /usr/local/lib/libldap-2.4.so.2 (0x806707000)
        liblber-2.4.so.2 => /usr/local/lib/liblber-2.4.so.2 (0x80694e000)
        libz.so.6 => /lib/libz.so.6 (0x806b5d000)
        libssl.so.9 => /usr/local/lib/libssl.so.9 (0x806d75000)
        libiconv.so.2 => /usr/local/lib/libiconv.so.2 (0x806fee000)
        libgmp.so.10 => /usr/local/lib/libgmp.so.10 (0x8072e9000)
        libavahi-common.so.3 => /usr/local/lib/libavahi-common.so.3 (0x807569000)
        libavahi-client.so.3 => /usr/local/lib/libavahi-client.so.3 (0x807775000)
        libgnutls.so.30 => /usr/local/lib/libgnutls.so.30 (0x807984000)
        libxslt.so.1 => /usr/local/lib/libxslt.so.1 (0x807d37000)
        libxml2.so.2 => /usr/local/lib/libxml2.so.2 (0x807f74000)
        liblzma.so.5 => /usr/lib/liblzma.so.5 (0x808307000)
        libffi.so.6 => /usr/local/lib/libffi.so.6 (0x808530000)
        libkvm.so.7 => /lib/libkvm.so.7 (0x808737000)
        librt.so.1 => /usr/lib/librt.so.1 (0x808945000)
        libdl.so.1 => /usr/lib/libdl.so.1 (0x808b4b000)
        libicui18n.so.63 => /usr/local/lib/libicui18n.so.63 (0x808e00000)
        libicuuc.so.63 => /usr/local/lib/libicuuc.so.63 (0x809309000)
        libicudata.so.63 => /usr/local/lib/libicudata.so.63 (0x8096eb000)
        libcxxrt.so.1 => /lib/libcxxrt.so.1 (0x8098ec000)
        libsasl2.so.3 => /usr/local/lib/libsasl2.so.3 (0x809b0b000)
        libexecinfo.so.1 => /usr/lib/libexecinfo.so.1 (0x809d28000)
        libc++.so.1 => /usr/lib/libc++.so.1 (0x809f2b000)
        libssl.so.8 => /usr/lib/libssl.so.8 (0x80a1f9000)
        libcrypto.so.8 => /lib/libcrypto.so.8 (0x80a600000)
        libintl.so.8 => /usr/local/lib/libintl.so.8 (0x80aa70000)
        libdbus-1.so.3 => /usr/local/lib/libdbus-1.so.3 (0x80ac7b000)
        libp11-kit.so.0 => /usr/local/lib/libp11-kit.so.0 (0x80aecb000)
        libtasn1.so.6 => /usr/local/lib/libtasn1.so.6 (0x80b1ec000)
        libnettle.so.6 => /usr/local/lib/libnettle.so.6 (0x80b401000)
        libhogweed.so.4 => /usr/local/lib/libhogweed.so.4 (0x80b639000)
        libidn2.so.4 => /usr/local/lib/libidn2.so.4 (0x80b86f000)
        libunistring.so.2 => /usr/local/lib/libunistring.so.2 (0x80ba8d000)
        libelf.so.2 => /lib/libelf.so.2 (0x80be41000)



Hi Odhiambo

Look at the following lines

        libGDLAccess.so.4.9 => /usr/local/lib/compat/pkg/libGDLAccess.so.4.9 (0x80143d000)
        libWEExtensions.so.4.9 => /usr/local/lib/compat/pkg/libWEExtensions.so.4.9 (0x801800000)
        libNGCards.so.4.9 => /usr/local/lib/compat/pkg/libNGCards.so.4.9 (0x801d36000)
        libNGObjWeb.so.4.9 => /usr/local/lib/compat/pkg/libNGObjWeb.so.4.9 (0x802000000)
        libNGMime.so.4.9 => /usr/local/lib/compat/pkg/libNGMime.so.4.9 (0x802c00000)
        libNGLdap.so.4.9 => /usr/local/lib/compat/pkg/libNGLdap.so.4.9 (0x80323b000)
        libNGStreams.so.4.9 => /usr/local/lib/compat/pkg/libNGStreams.so.4.9 (0x8034ad000)
        libNGExtensions.so.4.9 => /usr/local/lib/compat/pkg/libNGExtensions.so.4.9 (0x80380e000)
        libEOControl.so.4.9 => /usr/local/lib/compat/pkg/libEOControl.so.4.9 (0x803bdc000)
        libDOM.so.4.9 => /usr/local/lib/compat/pkg/libDOM.so.4.9 (0x803e8f000)
        libSaxObjC.so.4.9 => /usr/local/lib/compat/pkg/libSaxObjC.so.4.9 (0x80419d000)

The rigth path should be /usr/local/GNUstep/Local/Library/Libraries/ .

That much is clear.

Maybe your system has duplicate libraries at /usr/local/GNUstep/Local/Library/Libraries/.

No. I actually verified that.

It could be the manin reason for youor problem. Why it is installed on /usr/local/lib/compat/pkg/?

That is what I am wondering about. I never expected any files to be in  /usr/local/lib/compat/pkg.
The moment I delete the files in /usr/local/lib/compat/pkg, then I am able to start SOGo.

Are you using a custom package?

No. I am the type that don't like packages. I use them as last resort.

or are you compiling it from ports?

Yes.

Something in portupgrade is doing this, causing the problem.


--
Best regards,
Odhiambo WASHINGTON,
Nairobi,KE
+254 7 3200 0004/+254 7 2274 3223
"Oh, the cruft.", grep ^[^#] :-)


  • Re: [SOGo] SOGo won't start after updates, Odhiambo Washington, 03/09/2019

Archive powered by MHonArc 2.6.18.

Top of page