General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Why does EAS(exchange active sync) use wrong account name?


Chronological Thread 
  • From: "luckydog xf" ( ) < >
  • To:
  • Subject: Re: [SOGo] Why does EAS(exchange active sync) use wrong account name?
  • Date: Mon, 8 Apr 2019 17:37:10 +0800
  • Dmarc-filter: OpenDMARC Filter v1.2.0 mail.inverse.ca B3FAE1DE5198

Here is logs:


Apr 08 17:25:18 sogod [16322]: |SOGo| starting method 'OPTIONS' on uri '/SOGo/Microsoft-Server-ActiveSync'
Apr 08 17:25:18 sogod [16322]: |SOGo| request took 0.001262 seconds to execute
Apr 08 17:25:18 sogod [16322]: 172.16.234.223 "OPTIONS /SOGo/Microsoft-Server-ActiveSync HTTP/1.1" 200 0/0 0.002 - - 0
Apr 08 17:26:36 sogod [16322]: |SOGo| starting method 'OPTIONS' on uri '/SOGo/Microsoft-Server-ActiveSync'
Apr 08 17:26:36 sogod [16322]: |SOGo| request took 0.001592 seconds to execute
Apr 08 17:26:36 sogod [16322]: 172.16.234.223 "OPTIONS /SOGo/Microsoft-Server-ActiveSync HTTP/1.1" 200 0/0 0.003 - - 0
Apr 08 17:27:40 sogod [16322]: |SOGo| starting method 'OPTIONS' on uri '/SOGo/Microsoft-Server-ActiveSync'
Apr 08 17:27:40 sogod [16322]: |SOGo| request took 0.000844 seconds to execute
Apr 08 17:27:40 sogod [16322]: 172.16.234.223 "OPTIONS /SOGo/Microsoft-Server-ActiveSync HTTP/1.1" 200 0/0 0.001 - - 0

Anything wrong?


On Mon, Apr 8, 2019 at 3:15 PM luckydog xf < > wrote:
        LoginFieldNames = (c_uid, mail);

Add this optionals, so that either hongquan or works. But http access log is
172.16.81.56 - - [08/Apr/2019:14:14:47 +0800] "OPTIONS /Microsoft-Server-ActiveSync HTTP/1.1" 200 - "-" "Android/5.1-EAS-1.3"
while it's probably due to App version, it still cannot sync email.etc.

On Mon, Apr 8, 2019 at 12:49 PM luckydog xf < > wrote:
# logs

Apr 08 12:30:52 sogod [15247]: |SOGo| starting method 'OPTIONS' on uri '/SOGo/Microsoft-Server-ActiveSync'
2019-04-08 12:30:52.697 sogod[15247:15247] <MySQL4Channel[0x0x557eeed170f0] connection=0x0x557eeee23bc8> SQL: SELECT c_password FROM view WHERE c_uid = 'hongquan';
2019-04-08 12:30:52.698 sogod[15247:15247] <MySQL4Channel[0x0x557eeed170f0] connection=0x0x557eeee23bc8>   query has results, entering fetch-mode.
Apr 08 12:30:52 sogod [15247]: <0x0x557eeeafec40[SOGoDAVAuthenticator]> tried wrong password for user 'hongquan'!
Apr 08 12:30:52 sogod [15247]: |SOGo| request took 0.001318 seconds to execute

# exchange client setup
username:   ### I check that sogo reads account name specified here ###
domain name: ad.pthl.hk
password: XXXX
......

Actually in MariadDB c_uid is , NOT hongquan. But EAS use hongquan as query string of SQL statement.

Anything I can do to get rid of this ? Thanks.






Archive powered by MHonArc 2.6.18.

Top of page