General discussion on installation and configuration of SOGo

Text archives Help


RE: [SOGo] Encoding of Arabic (Windows-12256) Not Work


Chronological Thread 
  • From: "Jonathan Aquilina" ( ) < >
  • To: " " < >
  • Subject: RE: [SOGo] Encoding of Arabic (Windows-12256) Not Work
  • Date: Wed, 10 Jul 2019 16:37:29 +0000
  • Accept-language: en-US
  • Dmarc-filter: OpenDMARC Filter v1.2.0 mail.inverse.ca 5116A1DE4FB6

Hi,

 

The windows-1256 wont work as that is specific to microsoft windows only not your standard encoding in the earlier email he had shown en-US.utf8 which is not Arabic encoding on centos.

 

Regards,

Jonathan

 

From: < > On Behalf Of "Christian M. Jensen"
Sent: 10 July 2019 18:11
To:
Subject: Re: [SOGo] Encoding of Arabic (Windows-12256) Not Work

 

Hi.

Just tested a bit and can confirm this is an issue, and i think the problem is that SOGo has no rules for charset windows-1256 like for others as seen here.

https://github.com/inverse-inc/sogo/blob/60247e83e7da798bb7292521694812a6ea12ff0f/UI/MailPartViewers/UIxMailPartHTMLViewer.m#L82-L85

My suggesting is that you add this '{ @"windows-1256", XML_CHAR_ENCODING_ERROR},'  to UIxMailPartHTMLViewer.m between line 82/85 and compile SOGo to see if that helps, and report back.

Now this just a suggestion not tested so can't say if it will work. The reason i think this is where the issue resides, is as you can see by the image, title is fine but body is not, and the body part of the mail "look like" it parses through that method.

 

That's just my suggestion, hope you figure out what the root cause is.

-- 
Hilsen/Regards
Christian M. Jensen

 

On 10-07-2019 12:18, Eslam Basyouni ( ) wrote:

if you mean from where i'm open the SOGo web , there is no different , where i tested opening SOGo URL from Linux PC and from Windows PC and the same issue 

 

and if you or any one want to test with me do the following :

 

1- Send Email from Hotmail.com or outlook.com to your email on SOGo with Arabic like this    مرحبا... كيف الحال

2- open this mail from SOGo web and open the same mail from Thunderbird or out look and you will see how this mail will appear 

 

 

thank you for your reply 

 

 

 

 

On Tuesday, July 9, 2019, 09:56:17 PM GMT+2, Jonathan Aquilina < > wrote:

 

 

A quick question are you running sogo on windows or on linux?

 

Regards,

Jonathan

 

 


Thank you for your reply... Why when you send mail to yahoo or gmail from Microsoft there is no problem with encoding but only sogo that have the problem... I think sogo have problem with encoding 

 

I hope if we get any help where most of my emails in arabic.. And by the way if i open this email from thunderbird or outlook there is no problem i can see them with right encoding... 

 

 

 

On Tue, Jul 9, 2019 at 7:20 PM, Jonathan Aquilina

Im not a sogo expert but all I know is Microsoft have their own unique encodings for windows that are not compatible with standard encodings that one would find on linux or mac system.

 

Regards,

Jonathan

 

 

I got workaround to temporary read by forward the message, in this case i can see it, but we need to fix this bug...

Eng Ludovic , Francis, any chance of solving this issue , or any idea for workaround?

 

 

 

 

 

On Monday, July 8, 2019, 02:54:38 PM GMT+2, Mohammed Qanadelo < > wrote:

 

 

Dear all 

i have the same problem with arabic language in sogo

any solution's ? 

On 2019-07-07 10:35, Eslam Basyouni wrote:

 

Dears,

 

 

first of all i apologize the Arabic  encoding for (Windows-12356)  not for Arabic (Windows-12256)  , anyway i discovered that the only emails that come from Microsoft is only have this problem and all other is good like yahoo or gmail and any other have this problem, where ihad test with my exchange server and hostmail.com and outlook.com and they have this problem

 

 

 

 

On Sunday, July 7, 2019, 05:08:59 AM GMT+2, Eslam Basyouni < > wrote:

 

 

 

Dears,

 

i have  some emails in Arabic and it send from Exchange outlook to my email in sogo but it's contain bad character which it's not belong to Arabic , i think it's something related to encoding because i had send the same message from outlook after i change the encoding of outlook from Arabic (windows) to UTF-8 and i send again and there is no problem so  kindly  Advise..

 

Error! Filename not specified.


Error! Filename not specified.

 

 

-- 
Eng. Mohammed A. Qanadelo
  
Systems Development Department - GCC
  
Ministry of Telecomm. & Information Technology

PNG image




Archive powered by MHonArc 2.6.18.

Top of page