General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Encoding of Arabic (Windows-12256) Not Work


Chronological Thread 
  • From: "Eslam Basyouni" ( ) < >
  • To:
  • Subject: Re: [SOGo] Encoding of Arabic (Windows-12256) Not Work
  • Date: Thu, 11 Jul 2019 08:48:16 +0000 (UTC)
  • Dmarc-filter: OpenDMARC Filter v1.2.0 mail.inverse.ca EC0021DE4F9F

Dear Eng Christian M. Jensen,


i don't know how say thank you very very much , i appreciate your cooperation with me , you want me to add the configuration that you send and recompile from source is this right? 

if this the only way i will do this ,but what about to fix the current installed version , is there is any way to add any files or do any configuration??






On Wednesday, July 10, 2019, 07:08:33 PM GMT+2, Christian M. Jensen < > wrote:


hi again.

Just Tested hate leaving thing untested. Works yay! i attached path, this only adds  windows-1256 like i wrote earlier.


On 10-07-2019 18:10, "Christian M. Jensen" ( ) wrote:

Hi.

Just tested a bit and can confirm this is an issue, and i think the problem is that SOGo has no rules for charset windows-1256 like for others as seen here.

https://github.com/inverse-inc/sogo/blob/60247e83e7da798bb7292521694812a6ea12ff0f/UI/MailPartViewers/UIxMailPartHTMLViewer.m#L82-L85

My suggesting is that you add this '{ @"windows-1256", XML_CHAR_ENCODING_ERROR},'  to UIxMailPartHTMLViewer.m between line 82/85 and compile SOGo to see if that helps, and report back.

Now this just a suggestion not tested so can't say if it will work. The reason i think this is where the issue resides, is as you can see by the image, title is fine but body is not, and the body part of the mail "look like" it parses through that method.


That's just my suggestion, hope you figure out what the root cause is.

-- 
Hilsen/Regards
Christian M. Jensen
-- 
Hilsen/Regards
Christian M. Jensen
--

https://inverse.ca/sogo/lists

PNG image

PNG image




Archive powered by MHonArc 2.6.18.

Top of page