General discussion on installation and configuration of SOGo

Text archives Help


Re: [SOGo] Encoding of Arabic (Windows-12256) Not Work


Chronological Thread 
  • From: "Eslam Basyouni" ( ) < >
  • To:
  • Subject: Re: [SOGo] Encoding of Arabic (Windows-12256) Not Work
  • Date: Tue, 16 Jul 2019 08:55:21 +0000 (UTC)
  • Dmarc-filter: OpenDMARC Filter v1.2.0 mail.inverse.ca 451231DE5002

it's working with me in CentOS and i think ... yes can but make sure that you have the same path or change the path according to you path in ubuntu



On Monday, July 15, 2019, 01:55:58 AM GMT+2, Mohammed Qanadelo < > wrote:


dear eslam 

can i apply this in Ubuntu?

 

regards.  

On 2019-07-13 20:32, Eslam Basyouni wrote:

 
Dears,
 
i get the final configuration that can solved my problem by the following:
 

  copy MailPartViewers.SOGo.tar from your pc to /usr/lib64/GNUstep/SOGo/

  cd /usr/lib64/GNUstep/SOGo/

  mv MailPartViewers.SOGo MailPartViewers.SOGo.backup
 
  tar -xf MailPartViewers.SOGo.tar

  systemctl restart sogod

  systemctl restart memcached

 
On Friday, July 12, 2019, 03:54:28 PM GMT+2, Eslam Basyouni < > wrote:
 
 
 
Dear Eng Christian M. Jensen,
 
i want to thank you , your configuration solved the problem , where i compiled from the source after adding your patch and every thing is working good , so thank you again for you cooperation , i will added this issue to bug and i hope if they add more encoding from outlook application where most of people use it, and  to be added in the next version .
i would like to say thanks to everyone who try to help like Jonathan Aquilina and Gordon Messmer and Ludovic Marcotte 
 
 
On Thursday, July 11, 2019, 02:21:42 PM GMT+2, Christian M. Jensen < > wrote:
 
 

Hello.

I meant for you to try changing a few lines and recompile just to see if it will work.

To make this work you make the changes and compile SOGo, once SOGo has compiled, you just install that version over your current install (Make backups first). If this is a LIVE/Production server consider a cheap VPS just to test the changes, and avoid messing up your production setup.

You wrote you use CentOS so i would install a clone of the server on VPS or what you got available unless you are really confident.

How ever i do think this is the issue, and like Ludovic wrote in this message https://lists.inverse.ca/sogo/arc/users/2019-07/msg00046.html you need to create a bug report with a ZIP file containing sample messages (Sent from Outlook, Yahoo etc.).

Creating a bug report is the only way this will be tested and validated by SOGo developers, and in the end hopefully a fix makes it into SOGo for release.

-- 
Hilsen/Regards
Christian M. Jensen
On 11-07-2019 10:48, Eslam Basyouni ( ) wrote:
Dear Eng Christian M. Jensen,
 
 
i don't know how say thank you very very much , i appreciate your cooperation with me , you want me to add the configuration that you send and recompile from source is this right? 
 
if this the only way i will do this ,but what about to fix the current installed version , is there is any way to add any files or do any configuration??
 
--

https://inverse.ca/sogo/lists
--

https://inverse.ca/sogo/lists
--

https://inverse.ca/sogo/lists

 

-- 
Eng. Mohammed A. Qanadelo

Systems Development Department - GCC

Ministry of Telecomm. & Information Technology
--

https://inverse.ca/sogo/lists



Archive powered by MHonArc 2.6.18.

Top of page