General discussion on installation and configuration of SOGo

Text archives Help


[SOGo] SOGo 4.0.8 + Activesync + MySQL authentication issue


Chronological Thread 
  • From: "ej magpayo" ( ) < >
  • To:
  • Subject: [SOGo] SOGo 4.0.8 + Activesync + MySQL authentication issue
  • Date: Mon, 26 Aug 2019 21:30:17 +0800
  • Dmarc-filter: OpenDMARC Filter v1.2.0 mail.inverse.ca B32651DE5002

Hi!

I've been getting this weird error. I have successfully setup SOGo on Debian9 that with user source SQL. It can authenticate using the web interface but it fails on Android Outlook via EAS

Below is the chunk of log that shows why its failing..

Aug 26 21:18:17 sogod [2884]: |SOGo| starting method 'OPTIONS' on uri '/SOGo/Microsoft-Server-ActiveSync?Cmd=Options&User=ej&DeviceId=OPCC2C2983C14C9DE5159567EA4C096B&DeviceType=Outlook'
2019-08-26 21:18:17.677 sogod[2884:2884] <MySQL4Channel[0x0x55a2acffde20] connection=0x0x55a2acd4d368> SQL: SELECT c_password FROM sogo_users WHERE c_uid = ' ';
2019-08-26 21:18:17.677 sogod[2884:2884] <MySQL4Channel[0x0x55a2acffde20] connection=0x0x55a2acd4d368>   query has results, entering fetch-mode.
Aug 26 21:18:17 sogod [2884]: <0x0x55a2acfc9300[SOGoDAVAuthenticator]> tried wrong password for user ' '!
Aug 26 21:18:17 sogod [2884]: |SOGo| request took 0.001311 seconds to execute

The c_uid should only be testuser without the domain. Which results to authentication failure.

Hope someone can help me on this issue. TIA

Regards,




Archive powered by MHonArc 2.6.18.

Top of page